Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2169091 - New versions of libsepol available
Summary: New versions of libsepol available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libsepol
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Lautrbach
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-02-11 17:54 UTC by Upstream Release Monitoring
Modified: 2023-02-24 17:53 UTC (History)
4 users (show)

Fixed In Version: libsepol-3.5-0.rc3.1.fc39
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-02-15 05:13:10 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Upstream Release Monitoring 2023-02-11 17:54:59 UTC
Releases retrieved: checkpolicy-3.5-rc3, libselinux-3.5-rc3, libsemanage-3.5-rc3, mcstrans-3.5-rc3, policycoreutils-3.5-rc3, restorecond-3.5-rc3, secilc-3.5-rc3, selinux-dbus-3.5-rc3, selinux-gui-3.5-rc3, selinux-python-3.5-rc3, selinux-sandbox-3.5-rc3, semodule-utils-3.5-rc3, 3.5-rc3, 3.5-rc3
Upstream release that is considered latest: 20200710
Current version/release in rawhide: 3.5-0.rc2.1.fc38.1
URL: http://selinuxproject.org

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/1719/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/libsepol

Comment 1 Upstream Release Monitoring 2023-02-11 17:55:04 UTC
Scratch build failed. Details below:

GenericError: File upload failed: cli-build/1676138103.2350764.liixrMLO/libsepol-20200710-1.fc36.src.rpm
Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 198, in build
    output["build_id"] = self._scratch_build(session, package.name, srpm)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 451, in _scratch_build
    session.uploadWrapper(source, serverdir)
  File "/usr/lib/python3.10/site-packages/koji/__init__.py", line 3110, in uploadWrapper
    self.fastUpload(localfile, path, name, callback, blocksize, overwrite, volume=volume)
  File "/usr/lib/python3.10/site-packages/koji/__init__.py", line 3034, in fastUpload
    raise GenericError("File upload failed: %s/%s" % (path, name))

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Fedora Update System 2023-02-14 08:52:15 UTC
FEDORA-2023-d4e84745e4 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-d4e84745e4

Comment 3 Fedora Update System 2023-02-15 05:13:10 UTC
FEDORA-2023-d4e84745e4 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 4 Upstream Release Monitoring 2023-02-24 17:53:31 UTC
Scratch build failed. Details below:

GenericError: File upload failed: cli-build/1677261209.9352248.bHdbWtOA/libsepol-20200710-1.fc36.src.rpm
Traceback:
  File "/usr/local/lib/python3.10/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 198, in build
    output["build_id"] = self._scratch_build(session, package.name, srpm)
  File "/usr/local/lib/python3.10/site-packages/hotness/builders/koji.py", line 451, in _scratch_build
    session.uploadWrapper(source, serverdir)
  File "/usr/lib/python3.10/site-packages/koji/__init__.py", line 3110, in uploadWrapper
    self.fastUpload(localfile, path, name, callback, blocksize, overwrite, volume=volume)
  File "/usr/lib/python3.10/site-packages/koji/__init__.py", line 3034, in fastUpload
    raise GenericError("File upload failed: %s/%s" % (path, name))

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues


Note You need to log in before you can comment on or make changes to this bug.