Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2169726 - perl-bootstrap:5.36 FTBFS: perl-Encode: (perl-encoding, 3.00, 492.module_f39+16027+d6c4e89e, aarch64, 0) already exists
Summary: perl-bootstrap:5.36 FTBFS: perl-Encode: (perl-encoding, 3.00, 492.module_f39+...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora Modules
Classification: Fedora
Component: perl-bootstrap
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jitka Plesnikova
QA Contact: Fedora Extras Quality Assurance
URL: https://mbs.fedoraproject.org/module-...
Whiteboard:
Depends On:
Blocks: F39FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-02-14 14:00 UTC by Petr Pisar
Modified: 2023-02-16 13:16 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-02-16 13:16:24 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Petr Pisar 2023-02-14 14:00:25 UTC
perl-bootstrap:5.36 fails to build in Fedora 39 <https://mbs.fedoraproject.org/module-build-service/2/module-builds/16027> because perl-Encode component fails to build <https://koji.fedoraproject.org/koji/taskinfo?taskID=97456644>:

<class 'psycopg2.errors.UniqueViolation'>: duplicate key value violates unique constraint "rpminfo_unique_nvra"
DETAIL:  Key (name, version, release, arch, external_repo_id)=(perl-encoding, 3.00, 492.module_f39+16027+d6c4e89e, aarch64, 0) already exists.

The cause is perl-encoding binary package NEVRA conflicting among perl.spec and perl-Encode.spec.

Comment 1 Jitka Plesnikova 2023-02-16 13:16:24 UTC
Increase release in perl-Encode.spec. It is possible to build perl-bootstrap now.


Note You need to log in before you can comment on or make changes to this bug.