Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2170745 - postgresql:14 FTBFS: postgresql: Downloading postgresql-14.7-US.pdf: Server returned status code 404
Summary: postgresql:14 FTBFS: postgresql: Downloading postgresql-14.7-US.pdf: Server r...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora Modules
Classification: Fedora
Component: postgresql
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Filip Januš
QA Contact: Fedora Extras Quality Assurance
URL: https://mbs.fedoraproject.org/module-...
Whiteboard:
Depends On:
Blocks: F39FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-02-17 07:49 UTC by Petr Pisar
Modified: 2023-02-20 09:41 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-02-20 09:41:12 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Petr Pisar 2023-02-17 07:49:33 UTC
postgresql:14 module fails to build in Fedora 39 <https://mbs.fedoraproject.org/module-build-service/2/module-builds/16007> because postgresql component fails to build <https://koji.fedoraproject.org/koji/taskinfo?taskID=97589099>:

DEBUG util.py:540:  Executing command: ['fedpkg', 'sources'] with env {'TERM': 'vt100', 'SHELL': '/bin/bash', 'HOME': '/builddir', 'HOSTNAME': 'mock', 'PATH': '/usr/bin:/bin:/usr/sbin:/sbin', 'PROMPT_COMMAND': 'printf "\\033]0;<mock-chroot>\\007"', 'PS1': '<mock-chroot> \\s-\\v\\$ ', 'LANG': 'C.UTF-8'} and shell False
DEBUG util.py:443:    % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
DEBUG util.py:443:                                   Dload  Upload   Total   Spent    Left  Speed
DEBUG util.py:443:  
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100 20.4M  100 20.4M    0     0   154M      0 --:--:-- --:--:-- --:--:--  155M
DEBUG util.py:443:    % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
DEBUG util.py:443:                                   Dload  Upload   Total   Spent    Left  Speed
DEBUG util.py:443:  
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100    91  100    91    0     0   1732      0 --:--:-- --:--:-- --:--:--  1750
DEBUG util.py:443:    % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
DEBUG util.py:443:                                   Dload  Upload   Total   Spent    Left  Speed
DEBUG util.py:443:  
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100 21.1M  100 21.1M    0     0   148M      0 --:--:-- --:--:-- --:--:--  147M
DEBUG util.py:443:    % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
DEBUG util.py:443:                                   Dload  Upload   Total   Spent    Left  Speed
DEBUG util.py:443:  
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100    90  100    90    0     0   2027      0 --:--:-- --:--:-- --:--:--  2045
DEBUG util.py:443:    % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
DEBUG util.py:443:                                   Dload  Upload   Total   Spent    Left  Speed
DEBUG util.py:443:  
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100  151k  100  151k    0     0  2623k      0 --:--:-- --:--:-- --:--:-- 2650k
DEBUG util.py:443:    % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
DEBUG util.py:443:                                   Dload  Upload   Total   Spent    Left  Speed
DEBUG util.py:443:  
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
  0   196    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
DEBUG util.py:443:  curl: (22) The requested URL returned error: 404

This is caused by a mismatching sources record for postgresql-14.7-US.pdf:

$ fedpkg -v sources
Creating repo object from /home/petr/fedora/postgresql
Not downloading already downloaded postgresql-13.10.tar.bz2
Not downloading already downloaded postgresql-13.10.tar.bz2.sha256
Not downloading already downloaded postgresql-14.7.tar.bz2
Not downloading already downloaded postgresql-14.7.tar.bz2.sha256
Not downloading already downloaded postgresql-setup-8.8.tar.gz
Downloading postgresql-14.7-US.pdf
Full url: b'https://src.fedoraproject.org/repo/pkgs/rpms/postgresql/postgresql-14.7-US.pdf/sha512/5069ff8030f8bf780dfa026ee968aeb56f93e2f3625af63f145db83d879dd2a332a0994e184391ed502be9ec8a015ba895f098b4aa64cd56c9466d5cfde6b7fd/postgresql-14.7-US.pdf'
######################################################################## 100.0%
Remove downloaded invalid file /home/petr/fedora/postgresql/postgresql-14.7-US.pdf
Could not execute sources: Server returned status code 404


Note You need to log in before you can comment on or make changes to this bug.