Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 2170924 - update_platforms_check is constantly failing due to bad bash scripting
Summary: update_platforms_check is constantly failing due to bad bash scripting
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 9
Classification: Red Hat
Component: greenboot
Version: 9.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: 9.2
Assignee: Paul Whalen
QA Contact: Virtualization Bugs
Eliane Ramos Pereira
URL:
Whiteboard:
: 2115100 (view as bug list)
Depends On:
Blocks: IoT 2181296 2181297 2181542
TreeView+ depends on / blocked
 
Reported: 2023-02-17 17:08 UTC by Micah Abbott
Modified: 2023-05-09 09:26 UTC (History)
6 users (show)

Fixed In Version: greenboot-0.15.4-1.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 2181296 2181297 2181542 (view as bug list)
Environment:
Last Closed: 2023-05-09 07:54:41 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github fedora-iot greenboot issues 93 0 None closed Failing 01_update_platforms_check.sh on Fedora IoT 2023-02-17 17:10:42 UTC
Github fedora-iot greenboot pull 94 0 None Merged checks: update assignment of platform URLs var 2023-02-17 17:10:42 UTC
Red Hat Issue Tracker RHELPLAN-149101 0 None None None 2023-02-17 17:09:09 UTC
Red Hat Product Errata RHBA-2023:2438 0 None None None 2023-05-09 07:54:49 UTC

Description Micah Abbott 2023-02-17 17:08:43 UTC
See:  https://github.com/fedora-iot/greenboot/issues/93

The 01_update_platforms_check script is failing because the loop over the UPDATE_PLATFORM_URLS variable is treating the list of URLs as a single value.

The URLs need to be split and checked individually.

Comment 7 Xiaofeng Wang 2023-03-01 16:00:55 UTC
Verified on greenboot-0.15.4-1.el9.x86_64

Comment 9 Micah Abbott 2023-03-02 16:34:04 UTC
*** Bug 2115100 has been marked as a duplicate of this bug. ***

Comment 13 errata-xmlrpc 2023-05-09 07:54:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (greenboot bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2023:2438


Note You need to log in before you can comment on or make changes to this bug.