Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2171704 - reproc: FTBFS in Fedora rawhide/f38
Summary: reproc: FTBFS in Fedora rawhide/f38
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: reproc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact:
URL:
Whiteboard:
: 2226396 (view as bug list)
Depends On:
Blocks: F38FTBFS F39FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-02-20 12:02 UTC by Fedora Release Engineering
Modified: 2023-08-12 04:22 UTC (History)
1 user (show)

Fixed In Version: reproc-14.2.4-1.20230609git1c07bdb.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-08-12 04:22:37 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github DaanDeMeyer reproc issues 94 0 None open Build failure with gcc 13 2023-02-20 15:27:25 UTC

Description Fedora Release Engineering 2023-02-20 12:02:27 UTC
reproc failed to build from source in Fedora rawhide/f38

https://koji.fedoraproject.org/koji/taskinfo?taskID=96438923


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
Please fix reproc at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
reproc will be orphaned. Before branching of Fedora 39,
reproc will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 1 Orion Poplawski 2023-08-04 04:02:05 UTC
*** Bug 2226396 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Update System 2023-08-04 23:13:35 UTC
FEDORA-2023-dea9bc7696 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-dea9bc7696

Comment 3 Fedora Update System 2023-08-05 02:15:13 UTC
FEDORA-2023-dea9bc7696 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-dea9bc7696`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-dea9bc7696

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 4 Fedora Update System 2023-08-12 04:22:37 UTC
FEDORA-2023-dea9bc7696 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.