Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2172476 - F38FailsToInstall: budgie-desktop
Summary: F38FailsToInstall: budgie-desktop
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: budgie-desktop
Version: 38
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Joshua Strobl
QA Contact:
URL:
Whiteboard: RejectedBlocker AcceptedFreezeException
Depends On:
Blocks: F38FailsToInstall F38BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2023-02-22 11:47 UTC by Fedora Fails To Install
Modified: 2023-02-23 21:10 UTC (History)
3 users (show)

Fixed In Version: budgie-desktop-10.7.1-2.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-02-23 21:10:27 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Fails To Install 2023-02-22 11:47:54 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (budgie-desktop) Fails To Install in Fedora 38:

can't install budgie-desktop:
  - nothing provides libmutter-11.so.0()(64bit) needed by budgie-desktop-10.7.1-1.fc38.x86_64
  - nothing provides libmutter-clutter-11.so.0()(64bit) needed by budgie-desktop-10.7.1-1.fc38.x86_64
  - nothing provides libmutter-cogl-11.so.0()(64bit) needed by budgie-desktop-10.7.1-1.fc38.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-38-x86_64 --config-opts mirrored=False install budgie-desktop


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Fedora Update System 2023-02-22 14:05:19 UTC
FEDORA-2023-f3467a46d0 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-f3467a46d0

Comment 2 Fedora Blocker Bugs Application 2023-02-22 14:58:04 UTC
Proposed as a Blocker and Freeze Exception for 38-beta by Fedora user joshstrobl using the blocker tracking app because:

 The Mutter developers merged in an ABI change into F38 without rebuilding budgie-desktop or any communication with me about it. Without my rebuild, F38 will not be able to ship with a Budgie Spin because it will have a broken window manager.

Comment 3 Adam Williamson 2023-02-22 18:38:52 UTC
-3 blocker, +3 FE in https://pagure.io/fedora-qa/blocker-review/issue/1048 . Marking rejected as a blocker but accepted as an FE. This can't be a blocker because Budgie is not a release-blocking desktop, but it certainly deserves an FE.

Comment 4 Fedora Update System 2023-02-23 10:25:37 UTC
FEDORA-2023-f3467a46d0 has been pushed to the Fedora 38 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-f3467a46d0

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2023-02-23 21:10:27 UTC
FEDORA-2023-f3467a46d0 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.