Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2172489 - F38FailsToInstall: ghc-gi-harfbuzz, ghc-gi-harfbuzz-devel, ghc-gi-harfbuzz-prof
Summary: F38FailsToInstall: ghc-gi-harfbuzz, ghc-gi-harfbuzz-devel, ghc-gi-harfbuzz-prof
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ghc-gi-harfbuzz
Version: 38
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jens Petersen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: F38FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2023-02-22 11:48 UTC by Fedora Fails To Install
Modified: 2023-03-30 00:19 UTC (History)
1 user (show)

Fixed In Version: ghc-gi-harfbuzz-0.0.7-1.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-03-30 00:19:23 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Fails To Install 2023-02-22 11:48:17 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (ghc-gi-harfbuzz) Fails To Install in Fedora 38:

can't install ghc-gi-harfbuzz:
  - nothing provides libHSprimitive-0.7.3.0-HMedJdQUTCQ79SiIUfisnA-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHShashable-1.3.0.0-DKy9JIeMjEpEMnRxDSJKj1-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSvector-0.12.3.1-4ZUkvMG0hba9AHoOHt8bPP-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSunordered-containers-0.2.16.0-Dv4Rt1LQPww8MojiiwKOfx-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSrandom-1.2.0-KwELIRRPk7PAcyDfwXEvGo-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSsplitmix-0.1.0.3-EyzgLNoP6DEInch8Jq19NJ-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSattoparsec-0.13.2.5-4CNkT6xNlI9Gc8gs7Z5Bf8-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSinteger-logarithms-1.0.3.1-xsL5hmMYGlG65gkrXlNN-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSscientific-0.3.7.0-9Bte1MPl0IRAgeMv2NYBdP-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSansi-terminal-0.11.1-ueTKNpi6eZ9WH8Zhvi3SP-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSasync-2.2.4-ESduOyIMaQuAwwnNeo6WQh-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSblaze-builder-0.4.2.2-9YgzN2pqYG4eorbcqWPzo-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHScolour-2.3.6-2cl6zeh1tuv4LM4jVThjAx-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSnetwork-3.1.2.7-Ej7C9eZsuTEBnZvIiWsgMl-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSdata-default-class-0.1.2.0-4OJAKciMHbRGHw1F8M9yGO-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSstreaming-commons-0.2.2.4-6cxb1yVwqUe8phSLrKVZiy-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSzlib-0.6.2.3-8t4IsYh0zXNAXwjEV3rJFO-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSconduit-1.3.4.2-G0HnUQ7N2wA78v3y5fLVLL-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSmono-traversable-1.0.15.3-Gu9Z8H1koHkh05Tl75Vcp-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSresourcet-1.2.4.3-GMP8tRuYYp6Gpin0zi9eLe-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSsplit-0.2.3.4-IUvATEEGVazHDL4WYDj96v-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSunliftio-core-0.2.0.1-Hy41KxS3ore3s5ACrFOvp6-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSvector-algorithms-0.8.0.4-DQTpYmDhEZi8IhQORtqLqY-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSblaze-html-0.9.1.2-DF3eL85BuM282GkOoBmEJy-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSblaze-markup-0.8.2.8-9vgQQvanetSGq1hPLXsX6r-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSconduit-extra-1.3.5-4V2IwWvEwx4FMjMRxbGlHM-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSgi-glib-2.0.25-9ba7ldkNqHg33E8VlmHeYo-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSgi-gobject-2.0.26-3lZ8NpxQHzy8dSpQo4FzFj-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHShaskell-gi-0.25.0-5IMEG8loe7bLGW90OMdF5L-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHShaskell-gi-base-0.25.0-7MgIBYMSxJO2OxkSa21Hem-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHShaskell-lexer-1.1-1mQPYdpJu8R7Q5yNaiGvIK-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSpretty-show-1.10-LZeo5mRYHWT4tzUcUDlJ7N-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSregex-base-0.94.0.2-2OpFmMNhSGJJuB8R53JCoN-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSregex-tdfa-1.3.1.2-6TNnaPUqtDu2tNC0uJQ5MZ-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSsafe-0.3.19-8luuMyFSOlL6dBNapMpYT1-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHStyped-process-0.2.8.0-LCMRLGCZw73B0pGJQxSpVW-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSxdg-basedir-0.2.2-58j2GXHfnr5GECnaKTmbka-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSxml-conduit-1.9.1.1-La9VSTKxMUcIDwdyW13eNc-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  - nothing provides libHSxml-types-0.3.8-EHDLXpJVSNmLOCOBgCdOPq-ghc8.10.7.so()(64bit) needed by ghc-gi-harfbuzz-0.0.4-3.fc37.x86_64
  
can't install ghc-gi-harfbuzz-devel:
  - nothing provides ghc-devel(base-4.14.3.0) needed by ghc-gi-harfbuzz-devel-0.0.4-3.fc37.x86_64
  - nothing provides ghc-devel(bytestring-0.10.12.0) needed by ghc-gi-harfbuzz-devel-0.0.4-3.fc37.x86_64
  - nothing provides ghc-devel(text-1.2.4.1) needed by ghc-gi-harfbuzz-devel-0.0.4-3.fc37.x86_64
  - nothing provides ghc-devel(gi-glib-2.0.25-9ba7ldkNqHg33E8VlmHeYo) needed by ghc-gi-harfbuzz-devel-0.0.4-3.fc37.x86_64
  - nothing provides ghc-devel(gi-gobject-2.0.26-3lZ8NpxQHzy8dSpQo4FzFj) needed by ghc-gi-harfbuzz-devel-0.0.4-3.fc37.x86_64
  - nothing provides ghc-devel(haskell-gi-0.25.0-5IMEG8loe7bLGW90OMdF5L) needed by ghc-gi-harfbuzz-devel-0.0.4-3.fc37.x86_64
  - nothing provides ghc-devel(haskell-gi-base-0.25.0-7MgIBYMSxJO2OxkSa21Hem) needed by ghc-gi-harfbuzz-devel-0.0.4-3.fc37.x86_64
  - nothing provides ghc-compiler = 8.10.7 needed by ghc-gi-harfbuzz-devel-0.0.4-3.fc37.x86_64
  
can't install ghc-gi-harfbuzz-prof:
  - nothing provides ghc-prof(base-4.14.3.0) needed by ghc-gi-harfbuzz-prof-0.0.4-3.fc37.x86_64
  - nothing provides ghc-prof(bytestring-0.10.12.0) needed by ghc-gi-harfbuzz-prof-0.0.4-3.fc37.x86_64
  - nothing provides ghc-prof(text-1.2.4.1) needed by ghc-gi-harfbuzz-prof-0.0.4-3.fc37.x86_64
  - nothing provides ghc-prof(gi-glib-2.0.25-9ba7ldkNqHg33E8VlmHeYo) needed by ghc-gi-harfbuzz-prof-0.0.4-3.fc37.x86_64
  - nothing provides ghc-prof(gi-gobject-2.0.26-3lZ8NpxQHzy8dSpQo4FzFj) needed by ghc-gi-harfbuzz-prof-0.0.4-3.fc37.x86_64
  - nothing provides ghc-prof(haskell-gi-0.25.0-5IMEG8loe7bLGW90OMdF5L) needed by ghc-gi-harfbuzz-prof-0.0.4-3.fc37.x86_64
  - nothing provides ghc-prof(haskell-gi-base-0.25.0-7MgIBYMSxJO2OxkSa21Hem) needed by ghc-gi-harfbuzz-prof-0.0.4-3.fc37.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-38-x86_64 --config-opts mirrored=False install ghc-gi-harfbuzz ghc-gi-harfbuzz-devel ghc-gi-harfbuzz-prof


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Fedora Update System 2023-03-21 00:31:26 UTC
FEDORA-2023-4b5a5f3193 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-4b5a5f3193

Comment 2 Fedora Update System 2023-03-22 02:16:41 UTC
FEDORA-2023-4b5a5f3193 has been pushed to the Fedora 38 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-4b5a5f3193

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2023-03-30 00:19:23 UTC
FEDORA-2023-4b5a5f3193 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.