Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2172500 - F38FailsToInstall: rust-serial_test+document-features-devel
Summary: F38FailsToInstall: rust-serial_test+document-features-devel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rust-serial_test
Version: 38
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rust SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F38FailsToInstall F38BetaFreezeException
TreeView+ depends on / blocked
 
Reported: 2023-02-22 11:48 UTC by Fedora Fails To Install
Modified: 2023-02-28 17:00 UTC (History)
4 users (show)

Fixed In Version: rust-serial_test-1.0.0-2.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-02-28 17:00:58 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Fails To Install 2023-02-22 11:48:36 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (rust-serial_test) Fails To Install in Fedora 38:

can't install rust-serial_test+document-features-devel:
  - nothing provides (crate(document-features/default) >= 0.2.0 with crate(document-features/default) < 0.3.0~) needed by rust-serial_test+document-features-devel-1.0.0-1.fc38.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-38-x86_64 --config-opts mirrored=False install rust-serial_test+document-features-devel


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Fabio Valentini 2023-02-22 17:40:18 UTC
This issue was caused by an accidentally dropped patch when the 1.0.0 update was pushed shortly before the F38 freeze.
I cleaned this up shortly after, but the update landed only after the freeze went into effect.
https://bodhi.fedoraproject.org/updates/FEDORA-2023-16a8e1e46d

Comment 2 Fedora Fails To Install 2023-02-23 20:29:35 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 38.

Thanks for taking care of it!

Comment 3 Fedora Update System 2023-02-25 23:04:12 UTC
FEDORA-2023-16a8e1e46d has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-16a8e1e46d

Comment 4 Fedora Blocker Bugs Application 2023-02-25 23:07:28 UTC
Proposed as a Freeze Exception for 38-beta by Fedora user decathorpe using the blocker tracking app because:

 Update FEDORA-2023-16a8e1e46d fixes a FailsToInstall issue, which is currently only "fixed" by a buildroot override workaround (which is why automation already closed the bug, but the issue is still present without the buildroot override). I would like to not have to keep this override in place for the entire duration of the beta freeze, hence I am requesting a Freeze Exception.

Comment 5 František Zatloukal 2023-02-28 11:09:41 UTC
Discussed in ticket: https://pagure.io/fedora-qa/blocker-review/issue/1053

The decision to classify this bug as an FreezeException was made:

"We usually accept FTI issues as FEs as these can't be fixed post-release in the base repository."

Comment 6 Fedora Update System 2023-02-28 17:00:58 UTC
FEDORA-2023-16a8e1e46d has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.