Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2175123 - F38FailsToInstall: linphone, linphone-devel, linphone-mediastreamer, linphone-mediastreamer-devel
Summary: F38FailsToInstall: linphone, linphone-devel, linphone-mediastreamer, linphone...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: linphone
Version: 38
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Phil Wyett
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2177525 (view as bug list)
Depends On:
Blocks: F38FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2023-03-03 09:05 UTC by Fedora Fails To Install
Modified: 2023-07-20 00:35 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-03-10 17:21:10 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Fails To Install 2023-03-03 09:05:21 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (linphone) Fails To Install in Fedora 38:

can't install linphone:
  - nothing provides ortp(x86-64) >= 1:0.22.0 needed by linphone-3.6.1-50.fc38.x86_64
  - nothing provides libortp.so.9()(64bit) needed by linphone-3.6.1-50.fc38.x86_64
  
can't install linphone-devel:
  - nothing provides pkgconfig(ortp) needed by linphone-devel-3.6.1-50.fc38.x86_64
  
can't install linphone-mediastreamer:
  - nothing provides libortp.so.9()(64bit) needed by linphone-mediastreamer-3.6.1-50.fc38.x86_64
  
can't install linphone-mediastreamer-devel:
  - nothing provides pkgconfig(ortp) needed by linphone-mediastreamer-devel-3.6.1-50.fc38.x86_64
  - nothing provides ortp-devel(x86-64) needed by linphone-mediastreamer-devel-3.6.1-50.fc38.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-38-x86_64 --config-opts mirrored=False install linphone linphone-devel linphone-mediastreamer linphone-mediastreamer-devel


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Fedora Fails To Install 2023-03-10 12:06:07 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

This package fails to install and maintainers are advised to take one of the following actions:

 - Fix this bug and close this bugzilla once the update makes it to the repository.
   (The same script that posted this comment will eventually close this bugzilla
   when the fixed package reaches the repository, so you don't have to worry about it.)

or

 - Move this bug to ASSIGNED if you plan on fixing this, but simply haven't done so yet.

or

 - Orphan the package if you no longer plan to maintain it.


If you do not take one of these actions, the process at https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs will continue.
This package may be orphaned in 7+ weeks.
This is the first reminder (step 3) from the policy.

Don't hesitate to ask for help on devel.org if you are unsure how to fix this bug.

Comment 2 Phil Wyett 2023-03-10 17:21:10 UTC
This is a long term failure (years) that will be addressed hopefully in the 39 cycle. I do not have the time nor resources to fix this for the upcoming 38.

Comment 3 Jan Kratochvil 2023-07-20 00:29:48 UTC
*** Bug 2177525 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.