Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2176685 - python-sphinx: FTBFS in Fedora Rawhide (due to babel 2.12.x)
Summary: python-sphinx: FTBFS in Fedora Rawhide (due to babel 2.12.x)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-sphinx
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Karolina Surma
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F39FTBFS PYTHON3.12
TreeView+ depends on / blocked
 
Reported: 2023-03-08 22:53 UTC by Miro Hrončok
Modified: 2023-03-09 11:28 UTC (History)
6 users (show)

Fixed In Version: python-sphinx-5.3.0-4.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-03-09 11:28:41 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Miro Hrončok 2023-03-08 22:53:48 UTC
Description of problem:
Package python-sphinx fails to build from source in Fedora Rawhide.

Version-Release number of selected component (if applicable):
5.3.0-3.fc38

Steps to Reproduce:
fedpkg build

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-sphinx
-------------

This is due to https://github.com/sphinx-doc/sphinx/issues/11217 -- fix in https://github.com/sphinx-doc/sphinx/commit/c5641702b552d71bc99c1ba3b45073488a30d398

And https://github.com/sphinx-doc/sphinx/pull/11215 -- fix in https://github.com/sphinx-doc/sphinx/commit/44326fe2476db44e8c2a60d9326c9c3ac2865c03

Comment 2 Fedora Update System 2023-03-09 11:27:14 UTC
FEDORA-2023-78c0b738ed has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-78c0b738ed

Comment 3 Fedora Update System 2023-03-09 11:28:41 UTC
FEDORA-2023-78c0b738ed has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.