Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2180466 - pykka fails to build with Sphinx 6.1.3 and hence fails to install
Summary: pykka fails to build with Sphinx 6.1.3 and hence fails to install
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pykka
Version: 39
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tobias
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 2220086 (view as bug list)
Depends On: 1990633
Blocks: F39FTBFS F39FailsToInstall F40FailsToInstall F40FTBFS 2135122 PYTHON3.12 F39BetaFreezeException 2220041 2220042 2226017 2226018
TreeView+ depends on / blocked
 
Reported: 2023-03-21 14:34 UTC by Karolina Surma
Modified: 2023-09-06 23:37 UTC (History)
6 users (show)

Fixed In Version: pykka-2.0.2-17.fc40 pykka-2.0.2-17.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-06 23:37:52 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Fix-FTBFS-RHBZ-2180466.patch (deleted)
2023-07-14 17:05 UTC, Tobias
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Github jodal pykka issues 200 0 None open New release please 2023-07-14 17:09:44 UTC

Description Karolina Surma 2023-03-21 14:34:45 UTC
pykka fails to build with Sphinx 6.1.3 in Fedora 39 (currently Rawhide).

For the logs from testing build attempts, see:
https://copr.fedorainfracloud.org/coprs/ksurma/sphinx-6.1.3/package/pykka/

You can test you package in mock running:

$ mock -r fedora-rawhide-x86_64 --addrepo=https://download.copr.fedorainfracloud.org/results/ksurma/sphinx-6.1.3/fedora-rawhide-x86_64/ --no-clean your.src.rpm
$ mock -r fedora-rawhide-x86_64 --addrepo=https://download.copr.fedorainfracloud.org/results/ksurma/sphinx-6.1.3/fedora-rawhide-x86_64/ shell

The issue detected:

Exception occurred:
File "/usr/lib/python3.11/site-packages/sphinx/ext/extlinks.py", line 103, in role
title = caption % part
        ~~~~~~~~^~~~~~
TypeError: not all arguments converted during string formatting

It's an error in configuration.
To resolve, edit the documentation `conf.py` and correct the `extlinks` definition to contain exactly one `%s` in the captions, eg.

Bad:
'github': ('https://github.com/%s', '')

Good:
'github': ('https://github.com/%s', '%s')

Sphinx 6.1.3 will be included in Fedora 39.
Let us know here if you have any questions. Thank you!

Comment 1 Karolina Surma 2023-04-05 09:30:55 UTC
Hi,

This is a friendly notice that Sphinx 6.1.3 will be shipped to Fedora Rawhide on April 13th. This package - unless fixed - will start to FTBFS.
I'll be happy to help with fixing the issues, should you need it.
If this package has already been handled, please ignore this message and ideally close the ticket. Thank you!

Comment 2 Miro Hrončok 2023-07-10 07:08:55 UTC
*** Bug 2220086 has been marked as a duplicate of this bug. ***

Comment 3 Tobias 2023-07-14 17:05:51 UTC
Created attachment 1975833 [details]
Fix-FTBFS-RHBZ-2180466.patch

I've had a quick look at this and the attached patch makes it build on rawhide for me again.

Fabian, if you want to, please add me as co-maintainer.

Comment 4 Fedora Fails To Install 2023-07-17 07:25:28 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

This package fails to install and maintainers are advised to take one of the following actions:

 - Fix this bug and close this bugzilla once the update makes it to the repository.
   (The same script that posted this comment will eventually close this bugzilla
   when the fixed package reaches the repository, so you don't have to worry about it.)

or

 - Move this bug to ASSIGNED if you plan on fixing this, but simply haven't done so yet.

or

 - Orphan the package if you no longer plan to maintain it.


If you do not take one of these actions, the process at https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs will continue.
This package may be orphaned in 4+ weeks.
This is the second reminder (step 4) from the policy.

Don't hesitate to ask for help on devel.org if you are unsure how to fix this bug.

Comment 5 Fedora Fails To Install 2023-08-15 06:59:06 UTC
This package has been orphaned.

You can pick it up at https://src.fedoraproject.org/rpms/pykka by clicking button "Take". If nobody picks it up, it will be retired and removed from a distribution.

Comment 6 Fedora Release Engineering 2023-08-16 07:12:05 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 39 development cycle.
Changing version to 39.

Comment 7 Fedora Admin user for bugzilla script actions 2023-08-19 00:53:40 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 8 Fedora Fails To Install 2023-08-19 11:25:19 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

This package fails to install and maintainers are advised to take one of the following actions:

 - Fix this bug and close this bugzilla once the update makes it to the repository.
   (The same script that posted this comment will eventually close this bugzilla
   when the fixed package reaches the repository, so you don't have to worry about it.)

or

 - Move this bug to ASSIGNED if you plan on fixing this, but simply haven't done so yet.

or

 - Orphan the package if you no longer plan to maintain it.


If you do not take one of these actions, the process at https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs will continue.
This package may be orphaned in 7+ weeks.
This is the first reminder (step 3) from the policy.

Don't hesitate to ask for help on https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/ if you are unsure how to fix this bug.

Comment 9 Tobias 2023-08-19 12:35:46 UTC
Tried to rebuild this yesterday, but it's now blocked on a FTI dependency (Bug 1990633 / https://src.fedoraproject.org/rpms/python-greenlet/pull-request/8):

  - nothing provides python3.12dist(greenlet) >= 3~a1 needed by python3-gevent-23.7.0-2.fc39.x86_64

Comment 10 Fedora Update System 2023-09-01 19:06:34 UTC
FEDORA-2023-17290f7b7e has been submitted as an update to Fedora 40. https://bodhi.fedoraproject.org/updates/FEDORA-2023-17290f7b7e

Comment 11 Fedora Update System 2023-09-01 19:07:36 UTC
FEDORA-2023-17290f7b7e has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2023-09-03 16:18:15 UTC
FEDORA-2023-db10165e80 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-db10165e80

Comment 13 Fedora Update System 2023-09-04 01:49:15 UTC
FEDORA-2023-db10165e80 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-db10165e80`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-db10165e80

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Adam Williamson 2023-09-04 15:55:36 UTC
+3 in https://pagure.io/fedora-qa/blocker-review/issue/1255 , marking accepted.

Comment 15 Fedora Update System 2023-09-05 02:00:41 UTC
FEDORA-2023-db10165e80 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-db10165e80`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-db10165e80

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2023-09-06 01:31:49 UTC
FEDORA-2023-db10165e80 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-db10165e80`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-db10165e80

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2023-09-06 23:37:52 UTC
FEDORA-2023-db10165e80 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.