Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2184503 - F38FailsToInstall: rust-insta+dep_csv-devel
Summary: F38FailsToInstall: rust-insta+dep_csv-devel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rust-insta
Version: 38
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rust SIG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
Depends On:
Blocks: F38FailsToInstall F38FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2023-04-04 20:57 UTC by Fedora Fails To Install
Modified: 2023-04-11 22:33 UTC (History)
3 users (show)

Fixed In Version: rust-insta-1.29.0-2.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-04-11 22:33:51 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Fails To Install 2023-04-04 20:57:00 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (rust-insta) Fails To Install in Fedora 38:

can't install rust-insta+dep_csv-devel:
  - nothing provides crate(csv/default) = 1.1.6 needed by rust-insta+dep_csv-devel-1.29.0-1.fc38.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-38-x86_64 --config-opts mirrored=False install rust-insta+dep_csv-devel


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Fedora Update System 2023-04-10 19:43:18 UTC
FEDORA-2023-16d13a3573 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-16d13a3573

Comment 2 Fedora Blocker Bugs Application 2023-04-10 19:48:17 UTC
Proposed as a Freeze Exception for 38-final by Fedora user decathorpe using the blocker tracking app because:

 The linked FailsToInstall bug is addressed by update FEDORA-2023-16d13a3573. The update only fixes the installability issue and doesn't contain any other changes (the equivalent changes have already been pushed to stable in rawhide, and were also submitted to Fedora 37 and 36). I would like to have the version of this package that's shipped in the "fedora" repository to not have broken dependencies for the lifetime of Fedora 38.

Comment 3 Adam Williamson 2023-04-11 18:43:25 UTC
+4 in https://pagure.io/fedora-qa/blocker-review/issue/1146 , marking accepted.

Comment 4 Fedora Update System 2023-04-11 22:33:51 UTC
FEDORA-2023-16d13a3573 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.