Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2186381 - postgresql: FTBFS in Fedora Rawhide
Summary: postgresql: FTBFS in Fedora Rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: postgresql
Version: 38
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Filip Januš
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F39FTBFS F40FTBFS PYTHON3.12
TreeView+ depends on / blocked
 
Reported: 2023-04-13 05:39 UTC by Tomáš Hrnčiar
Modified: 2023-09-13 07:36 UTC (History)
11 users (show)

Fixed In Version: postgresql-15.4-1.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-13 07:36:06 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Tomáš Hrnčiar 2023-04-13 05:39:43 UTC
Description of problem:
Package postgresql fails to build from source in Fedora Rawhide.

Version-Release number of selected component (if applicable):
15.1-2.fc38

Steps to Reproduce:
koji build --scratch f39 postgresql-15.1-2.fc38.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/postgresql

Comment 1 Tom Lane 2023-04-14 14:21:11 UTC
I don't think this has anything to do with Python --- it looks like an LLVM compatibility issue.  Postgres has been letting LLVM's opaque-pointer changes slide, so there's no upstream fix for this yet.  I'll try to stir up some action, but I think the only short-term fix is to delete --with-llvm from the configure options for rawhide.

Comment 2 Tomáš Hrnčiar 2023-04-17 08:13:21 UTC
I have added the PYTHON3.12 tracker so postgresql is ignored by our tooling, feel free to ignore the label.

Comment 3 Fedora Release Engineering 2023-08-16 07:13:24 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 39 development cycle.
Changing version to 39.

Comment 4 Petr Pisar 2023-09-13 07:36:06 UTC
According to Koschei history this failure first appeared with an upgrade of llvm-devel from 15.0.7-2.fc38 to 16.0.0-2.fc38 <https://koschei.fedoraproject.org/build/15267356> and was fixed in postgresql-15.4-1.fc38 and postgresql-15.3-1.fc39.


Note You need to log in before you can comment on or make changes to this bug.