Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2189658 - python-werkzeug-3.0.1 is available
Summary: python-werkzeug-3.0.1 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-werkzeug
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: František Zatloukal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 2220234
TreeView+ depends on / blocked
 
Reported: 2023-04-25 20:20 UTC by Upstream Release Monitoring
Modified: 2024-01-03 18:24 UTC (History)
7 users (show)

Fixed In Version: python-werkzeug-3.0.1-1.fc40
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-01-03 18:24:12 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Update to 2.3.0 (#2189658) (deleted)
2023-04-25 20:20 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 2.3.1 (#2189658) (deleted)
2023-04-27 13:46 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 2.3.2 (#2189658) (deleted)
2023-04-28 19:03 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 2.3.3 (#2189658) (deleted)
2023-05-01 15:33 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 2.3.4 (#2189658) (deleted)
2023-05-08 22:19 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 2.3.5 (#2189658) (deleted)
2023-06-07 19:48 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 2.3.6 (#2189658) (deleted)
2023-06-08 21:28 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 2.3.7 (#2189658) (deleted)
2023-08-14 11:43 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 3.0.0 (#2189658) (deleted)
2023-09-30 15:49 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 3.0.1 (#2189658) (deleted)
2023-10-24 22:34 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 3.0.1 (#2189658) (deleted)
2023-11-08 19:45 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2023-04-25 20:20:05 UTC
Releases retrieved: 2.3.0
Upstream release that is considered latest: 2.3.0
Current version/release in rawhide: 2.2.3-1.fc39
URL: https://pypi.python.org/pypi/Werkzeug

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4092/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-werkzeug

Comment 1 Upstream Release Monitoring 2023-04-25 20:20:10 UTC
Created attachment 1959910 [details]
Update to 2.3.0 (#2189658)

Comment 2 Upstream Release Monitoring 2023-04-25 20:31:54 UTC
the-new-hotness/release-monitoring.org's scratch build of python-werkzeug-2.3.0-1.fc36.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=100388737

Comment 3 Upstream Release Monitoring 2023-04-27 13:45:56 UTC
Releases retrieved: 2.3.1
Upstream release that is considered latest: 2.3.1
Current version/release in rawhide: 2.2.3-1.fc39
URL: https://pypi.python.org/pypi/Werkzeug

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4092/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-werkzeug

Comment 4 Upstream Release Monitoring 2023-04-27 13:46:01 UTC
Created attachment 1960391 [details]
Update to 2.3.1 (#2189658)

Comment 5 Upstream Release Monitoring 2023-04-27 13:50:30 UTC
the-new-hotness/release-monitoring.org's scratch build of python-werkzeug-2.3.1-1.fc36.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=100451087

Comment 6 Upstream Release Monitoring 2023-04-28 19:03:24 UTC
Releases retrieved: 2.3.2
Upstream release that is considered latest: 2.3.2
Current version/release in rawhide: 2.2.3-1.fc39
URL: https://pypi.python.org/pypi/Werkzeug

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4092/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-werkzeug

Comment 7 Upstream Release Monitoring 2023-04-28 19:03:28 UTC
Created attachment 1960885 [details]
Update to 2.3.2 (#2189658)

Comment 8 Upstream Release Monitoring 2023-04-28 19:08:03 UTC
the-new-hotness/release-monitoring.org's scratch build of python-werkzeug-2.3.2-1.fc36.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=100495125

Comment 9 Upstream Release Monitoring 2023-05-01 15:33:10 UTC
Releases retrieved: 2.3.3
Upstream release that is considered latest: 2.3.3
Current version/release in rawhide: 2.2.3-1.fc39
URL: https://pypi.python.org/pypi/Werkzeug

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4092/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-werkzeug

Comment 10 Upstream Release Monitoring 2023-05-01 15:33:14 UTC
Created attachment 1961447 [details]
Update to 2.3.3 (#2189658)

Comment 11 Upstream Release Monitoring 2023-05-01 15:38:18 UTC
the-new-hotness/release-monitoring.org's scratch build of python-werkzeug-2.3.3-1.fc36.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=100604685

Comment 12 Upstream Release Monitoring 2023-05-08 22:19:26 UTC
Releases retrieved: 2.3.4
Upstream release that is considered latest: 2.3.4
Current version/release in rawhide: 2.2.3-1.fc39
URL: https://pypi.python.org/pypi/Werkzeug

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4092/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-werkzeug

Comment 13 Upstream Release Monitoring 2023-05-08 22:19:32 UTC
Created attachment 1963419 [details]
Update to 2.3.4 (#2189658)

Comment 14 Upstream Release Monitoring 2023-05-08 22:24:39 UTC
the-new-hotness/release-monitoring.org's scratch build of python-werkzeug-2.3.4-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=100911977

Comment 15 Upstream Release Monitoring 2023-06-07 19:48:20 UTC
Releases retrieved: 2.3.5
Upstream release that is considered latest: 2.3.5
Current version/release in rawhide: 2.2.3-1.fc39
URL: https://pypi.python.org/pypi/Werkzeug

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4092/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-werkzeug

Comment 16 Upstream Release Monitoring 2023-06-07 19:48:25 UTC
Created attachment 1969590 [details]
Update to 2.3.5 (#2189658)

Comment 17 Upstream Release Monitoring 2023-06-07 19:56:05 UTC
the-new-hotness/release-monitoring.org's scratch build of python-werkzeug-2.3.5-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=101915553

Comment 18 Upstream Release Monitoring 2023-06-08 21:28:30 UTC
Releases retrieved: 2.3.6
Upstream release that is considered latest: 2.3.6
Current version/release in rawhide: 2.2.3-1.fc39
URL: https://pypi.python.org/pypi/Werkzeug

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4092/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-werkzeug

Comment 19 Upstream Release Monitoring 2023-06-08 21:28:43 UTC
Created attachment 1969828 [details]
Update to 2.3.6 (#2189658)

Comment 20 Upstream Release Monitoring 2023-06-08 21:32:55 UTC
the-new-hotness/release-monitoring.org's scratch build of python-werkzeug-2.3.6-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=101951093

Comment 21 Upstream Release Monitoring 2023-08-14 11:43:22 UTC
Releases retrieved: 2.3.7
Upstream release that is considered latest: 2.3.7
Current version/release in rawhide: 2.2.3-3.fc39
URL: https://pypi.python.org/pypi/Werkzeug

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4092/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-werkzeug

Comment 22 Upstream Release Monitoring 2023-08-14 11:43:26 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-pb8zy7zg/python-werkzeug.spec']' returned non-zero exit status 1.

StdOut:
setting SOURCE_DATE_EPOCH=1691971200
error: Bad file: ./Werkzeug-2.3.7.tar.gz: No such file or directory

RPM build errors:
    Bad file: ./Werkzeug-2.3.7.tar.gz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 229, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 23 Upstream Release Monitoring 2023-08-14 11:43:27 UTC
Created attachment 1983268 [details]
Update to 2.3.7 (#2189658)

Comment 24 Upstream Release Monitoring 2023-09-30 15:49:18 UTC
Releases retrieved: 3.0.0
Upstream release that is considered latest: 3.0.0
Current version/release in rawhide: 2.2.3-3.fc39
URL: https://pypi.python.org/pypi/Werkzeug

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4092/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-werkzeug

Comment 25 Upstream Release Monitoring 2023-09-30 15:49:22 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-_n8fcy90/python-werkzeug.spec']' returned non-zero exit status 1.

StdOut:
setting SOURCE_DATE_EPOCH=1696032000
error: Bad file: ./Werkzeug-3.0.0.tar.gz: No such file or directory

RPM build errors:
    Bad file: ./Werkzeug-3.0.0.tar.gz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 229, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 26 Upstream Release Monitoring 2023-09-30 15:49:24 UTC
Created attachment 1991315 [details]
Update to 3.0.0 (#2189658)

Comment 27 Upstream Release Monitoring 2023-10-24 22:34:30 UTC
Releases retrieved: 3.0.1
Upstream release that is considered latest: 3.0.1
Current version/release in rawhide: 2.2.3-3.fc39
URL: https://pypi.python.org/pypi/Werkzeug

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/4092/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/python-werkzeug

Comment 28 Upstream Release Monitoring 2023-10-24 22:34:33 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-l7mn_nl9/python-werkzeug.spec']' returned non-zero exit status 1.

StdOut:
setting SOURCE_DATE_EPOCH=1698105600
error: Bad file: ./Werkzeug-3.0.1.tar.gz: No such file or directory

RPM build errors:
    Bad file: ./Werkzeug-3.0.1.tar.gz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 229, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 29 Upstream Release Monitoring 2023-10-24 22:34:35 UTC
Created attachment 1995324 [details]
Update to 3.0.1 (#2189658)

Comment 30 Upstream Release Monitoring 2023-11-08 19:45:10 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-ut0w1kh4/python-werkzeug.spec']' returned non-zero exit status 1.

StdOut:
setting SOURCE_DATE_EPOCH=1699401600
error: Bad file: ./Werkzeug-3.0.1.tar.gz: No such file or directory

RPM build errors:
    Bad file: ./Werkzeug-3.0.1.tar.gz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 229, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 31 Upstream Release Monitoring 2023-11-08 19:45:11 UTC
Created attachment 1997912 [details]
Update to 3.0.1 (#2189658)

Comment 32 Fedora Update System 2024-01-03 18:08:35 UTC
FEDORA-2024-512456951a has been submitted as an update to Fedora 40. https://bodhi.fedoraproject.org/updates/FEDORA-2024-512456951a

Comment 33 Fedora Update System 2024-01-03 18:24:12 UTC
FEDORA-2024-512456951a has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.