Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2189915 - python-lxml: FTBFS in Fedora Rawhide: test_html_prefix_nsmap: AttributeError: 'NoneType' object has no attribute 'nsmap'
Summary: python-lxml: FTBFS in Fedora Rawhide: test_html_prefix_nsmap: AttributeError:...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-lxml
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Python Maintainers
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
: 2192588 (view as bug list)
Depends On:
Blocks: F39FTBFS PYTHON3.12
TreeView+ depends on / blocked
 
Reported: 2023-04-26 12:29 UTC by Miro Hrončok
Modified: 2023-06-07 12:18 UTC (History)
10 users (show)

Fixed In Version: python-lxml-4.9.2-3.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-06-07 12:18:52 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad.net lxml/+bug/2016939 0 None None None 2023-05-03 09:35:16 UTC

Description Miro Hrončok 2023-04-26 12:29:20 UTC
Description of problem:
Package python-lxml fails to build from source in Fedora Rawhide.

======================================================================
ERROR: test_html_prefix_nsmap (lxml.tests.test_etree.ETreeOnlyTestCase.test_html_prefix_nsmap)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/usr/lib64/python3.11/unittest/case.py", line 57, in testPartExecutor
    yield
  File "/usr/lib64/python3.11/unittest/case.py", line 623, in run
    self._callTestMethod(testMethod)
  File "/usr/lib64/python3.11/unittest/case.py", line 579, in _callTestMethod
    if method() is not None:
       ^^^^^^^^
  File "/builddir/build/BUILD/lxml-4.9.2/src/lxml/tests/test_etree.py", line 3076, in test_html_prefix_nsmap
    self.assertEqual({}, el.nsmap)
                         ^^^^^^^^
AttributeError: 'NoneType' object has no attribute 'nsmap'
----------------------------------------------------------------------

Version-Release number of selected component (if applicable):
4.9.2-2.fc38

Steps to Reproduce:
fedpkg build

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-lxml

Comment 1 Miro Hrončok 2023-05-02 12:10:37 UTC
*** Bug 2192588 has been marked as a duplicate of this bug. ***

Comment 2 Tomáš Hrnčiar 2023-05-02 12:57:05 UTC
The culprit is in libxml2, the failing test works with libxml2 2.10.3. I am gonna try to build the latest version 2.11.1.

Comment 3 Tomáš Hrnčiar 2023-05-03 08:28:03 UTC
I find out that the failing test passes if this commit (https://gitlab.gnome.org/GNOME/libxml2/-/commit/73210eeda5782da3414517cab20550d137e2dd25) is reverted.

Comment 4 Tomáš Hrnčiar 2023-05-03 08:30:31 UTC
Also building the latest version 2.11.1 didn't help. Hence I was looking for a problematic commit between 2.10.3 and 2.10.4.

Comment 5 Yaakov Selkowitz 2023-05-24 01:54:57 UTC
Please note that this is blocking ELN minimization efforts in preparation for RHEL 10 as filed in https://src.fedoraproject.org/rpms/python-lxml/pull-request/25


Note You need to log in before you can comment on or make changes to this bug.