Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2192078 - F38FailsToInstall: python3-plotnine+extra
Summary: F38FailsToInstall: python3-plotnine+extra
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-plotnine
Version: 38
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sandro
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: F38FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2023-04-29 09:12 UTC by Fedora Fails To Install
Modified: 2023-05-18 01:56 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-05-18 01:56:55 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Fails To Install 2023-04-29 09:12:30 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (python-plotnine) Fails To Install in Fedora 38:

can't install python3-plotnine+extra:
  - nothing provides python3.11dist(scikit-misc) needed by python3-plotnine+extra-0.10.1-6.fc38.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-38-x86_64 --config-opts mirrored=False install python3-plotnine+extra


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Ben Beasley 2023-04-29 14:47:35 UTC
This is a problem in F39, F38, and F37.

The root cause is that the python-scikit-misc package, as built, does not include any Python metadata, so the automatic generators do not provide python3dist(scikit-misc) etc.

We should probably try to build it with pyproject-rpm-macros rather than using meson directly; it’s likely that this will furnish the missing dist-info metadata. That will require packaging python-meson-python.

Comment 2 Sandro 2023-04-29 15:34:58 UTC
> The root cause is that the python-scikit-misc package, as built, does not
> include any Python metadata, so the automatic generators do not provide
> python3dist(scikit-misc) etc.

I wonder how that affects the PyPI release...

Comment 3 Ben Beasley 2023-04-29 16:06:42 UTC
(In reply to Sandro from comment #2)
> > The root cause is that the python-scikit-misc package, as built, does not
> > include any Python metadata, so the automatic generators do not provide
> > python3dist(scikit-misc) etc.
> 
> I wonder how that affects the PyPI release...

I suspect everything is fine when using the meson-python layer, and the meson build system is subordinate to the Python one.

I’ve submitted python-meson-python for review (bug 2192109) but haven’t had a chance to try to build python-scikit-misc using it yet. It should be pretty straightforward except for figuring out how to control the meson options.

Comment 4 Sandro 2023-04-29 21:54:08 UTC
> > I wonder how that affects the PyPI release...
> 
> I suspect everything is fine when using the meson-python layer, and the
> meson build system is subordinate to the Python one.

Yeah. I have a better understanding now of how this works in the Python ecosystem.

As I mentioned elsewhere, the presence of meson.build files sent me down the wrong track. That and being blissfully unaware of the existence of mesonpy.

Comment 5 Fedora Update System 2023-05-09 11:12:03 UTC
FEDORA-2023-45d127eadb has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-45d127eadb

Comment 6 Fedora Update System 2023-05-10 02:00:12 UTC
FEDORA-2023-45d127eadb has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-45d127eadb`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-45d127eadb

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 7 Fedora Update System 2023-05-18 01:56:55 UTC
FEDORA-2023-45d127eadb has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.