Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2196755 - perl-IO-Async-0.802-2.fc39 FTBFS: A build dependency on Test::Future::IO::Impl is not declared
Summary: perl-IO-Async-0.802-2.fc39 FTBFS: A build dependency on Test::Future::IO::Imp...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-IO-Async
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Emmanuel Seyman
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F39FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-05-10 06:31 UTC by Petr Pisar
Modified: 2023-05-14 09:51 UTC (History)
3 users (show)

Fixed In Version: perl-IO-Async-0.802-3.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-05-14 09:51:18 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Petr Pisar 2023-05-10 06:31:47 UTC
perl-IO-Async-0.802-2.fc39 fails to build in Fedora 39 because a test fails:

t/64handle-bind.t ............ ok
Can't locate Test/Future/IO/Impl.pm in @INC (you may need to install the Test::Future::IO::Impl module)
 (@INC contains: /builddir/build/BUILD/IO-Async-0.802/blib/lib /builddir/build/BUILD/IO-Async-0.802/bli
b/arch /usr/local/lib64/perl5/5.36 /usr/local/share/perl5/5.36 /usr/lib64/perl5/vendor_perl /usr/share/
perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at t/70future-io.t line 9.
BEGIN failed--compilation aborted at t/70future-io.t line 9.
t/70future-io.t .............. 
Dubious, test returned 2 (wstat 512, 0x200)
No subtests run 

It seems that a spec file is missing a build dependency on that module.

This failure is triggered by upgrading perl-Future-IO from 0.13-1.fc39 to 0.14-1.fc39:

Revision history for Future-IO
 
0.14    2023-04-25
        [CHANGES]
         * Moved `Test::Future::IO::Impl` into its own distribution, so that
           downstream packages don't have to runtime-depend on `Test2`

Reproducible: Always

Comment 1 Emmanuel Seyman 2023-05-14 09:51:18 UTC
Thank you for the bug report, Petr.

I've added the needed BR and rebuild the package for rawhide:
https://koji.fedoraproject.org/koji/buildinfo?buildID=2199717


Note You need to log in before you can comment on or make changes to this bug.