Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2208278 - perl-Graphics-TIFF-19-4.fc39 FTBFS: t/1.t fails with ImageMagick-7.1.1.8
Summary: perl-Graphics-TIFF-19-4.fc39 FTBFS: t/1.t fails with ImageMagick-7.1.1.8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Graphics-TIFF
Version: 38
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F39FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-05-18 13:19 UTC by Petr Pisar
Modified: 2023-05-30 02:03 UTC (History)
2 users (show)

Fixed In Version: perl-Graphics-TIFF-19-5.fc39 perl-Graphics-TIFF-19-5.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-05-30 02:03:06 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
CPAN 148337 0 None None None 2023-05-18 13:49:16 UTC

Description Petr Pisar 2023-05-18 13:19:16 UTC
perl-Graphics-TIFF-19-4.fc39 fails to build in Fedora 39 because a test fails:

$ prove -b t/1.t
t/1.t .. 1/50 
#   Failed test 'PrintDirectory'
#   at t/1.t line 122.
#          got: '466'
#     expected: '449'

#   Failed test 'tiffcmp'
#   at t/1.t line 157.
#          got: 'XPosition tag appears only in /tmp/MkyBKzzTV7/test.tif
# '
#     expected: ''
# Looks like you failed 2 tests of 50.
t/1.t .. Dubious, test returned 2 (wstat 512, 0x200)
Failed 2/50 subtests 

This is triggered by upgrading ImageMagick from 1:7.1.1.4-3.fc39 to 1:7.1.1.8-1.fc39.

Reproducible: Always

Comment 1 Fedora Update System 2023-05-18 16:18:05 UTC
FEDORA-2023-666098f732 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-666098f732

Comment 2 Fedora Update System 2023-05-19 02:20:23 UTC
FEDORA-2023-666098f732 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-666098f732`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-666098f732

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2023-05-30 02:03:06 UTC
FEDORA-2023-666098f732 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.