Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2208279 - perl-Module-CPANfile-1.1004-16.fc39 FTBFS: t/from_prereqs.t fails with perl-CPAN-Meta-Requirements-2.142-1.fc39
Summary: perl-Module-CPANfile-1.1004-16.fc39 FTBFS: t/from_prereqs.t fails with perl-C...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-CPAN-Meta-Requirements
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Paul Howarth
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F39FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-05-18 13:25 UTC by Petr Pisar
Modified: 2023-05-31 13:34 UTC (History)
5 users (show)

Fixed In Version: perl-CPAN-Meta-Requirements-2.142-2.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-05-31 13:34:33 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github Perl-Toolchain-Gang CPAN-Meta-Requirements pull 38 0 None open Fix regression with implicit minimum value and multiple requirements 2023-05-19 11:04:17 UTC

Description Petr Pisar 2023-05-18 13:25:57 UTC
perl-Module-CPANfile-1.1004-16.fc39 fails to build in Fedora 39 because a test fails:

#   Failed test at t/from_prereqs.t line 21.
#          got: 'requires 'DBI';
# requires 'Plack', '1.0001';
# requires 'perl', '5.008001';
# 
# on test => sub {
#     requires 'Test::More', '0.90';
# };
# '
#     expected: 'requires 'DBI';
# requires 'Plack', '1.0001';
# requires 'perl', '5.008001';
# 
# on test => sub {
#     requires 'Test::More', '>= 0.90, != 0.91';
# };
# '
# Looks like you failed 1 test of 3.
t/from_prereqs.t ....... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/3 subtests 

A difference between passing and failing build root is at <https://koschei.fedoraproject.org/build/15477723>. This failure is very probably triggered by upgrading perl-CPAN-Meta-Requirements from 2.140-491.fc39 to 2.142-1.fc39.

Reproducible: Always

Comment 1 Petr Pisar 2023-05-31 12:05:51 UTC
Thanks, Paul, for the patch in CPAN-Meta-Requirements in upstream. I confirm that it makes perl-Module-CPANfile passing again.

Comment 2 Petr Pisar 2023-05-31 12:08:44 UTC
This also affects perl-Pinto-0.14-18.fc39:

t/01-common/01-types.t ................ ok
    #   Failed test 'Target Foo::Bar~1.2, <= 1.9, != 1.5 should not be satisfied by 1.5'
    #   at t/01-common/02-target-package.t line 94.
    #   Failed test 'Target Foo::Bar~1.2, <= 1.9, != 1.5 should not be satisfied by 2.0'
    #   at t/01-common/02-target-package.t line 94.
    # Looks like you failed 2 tests of 29.
#   Failed test 'version specifications'
#   at t/01-common/02-target-package.t line 97.
# Looks like you failed 1 test of 5.
t/01-common/02-target-package.t ....... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/5 subtests

Comment 3 Fedora Update System 2023-05-31 13:33:44 UTC
FEDORA-2023-fd746f0816 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-fd746f0816

Comment 4 Fedora Update System 2023-05-31 13:34:33 UTC
FEDORA-2023-fd746f0816 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.