Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2208967 - perl-GnuPG-Interface-1.02-7.fc39 FTBFS: tests fail with gnupg2-2.4.1
Summary: perl-GnuPG-Interface-1.02-7.fc39 FTBFS: tests fail with gnupg2-2.4.1
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-GnuPG-Interface
Version: 39
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Emmanuel Seyman
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F39FTBFS F40FTBFS 2239168
TreeView+ depends on / blocked
 
Reported: 2023-05-22 08:26 UTC by Petr Pisar
Modified: 2023-12-17 07:48 UTC (History)
4 users (show)

Fixed In Version: perl-GnuPG-Interface-1.04-2.fc40
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-12-17 07:48:14 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Petr Pisar 2023-05-22 08:26:17 UTC
perl-GnuPG-Interface-1.02-7.fc39 fails to build in Fedora 39 because tests fail:

t/Fingerprint.t ............ ok
t/get_public_keys.t ........ 
Failed 2/3 subtests 
t/get_secret_keys.t ........ 
Failed 1/2 subtests 
t/import_keys.t ............ ok
t/Interface.t .............. ok
t/list_public_keys.t ....... ok
t/list_secret_keys.t ....... 
Failed 1/4 subtests 
t/list_sigs.t .............. ok
t/passphrase_handling.t .... ok
t/sign.t ................... ok
t/sign_and_encrypt.t ....... ok
t/UserId.t ................. ok
t/verify.t ................. ok
t/version_updates.t ........ ok
t/wrap_call.t .............. ok
t/z_delete_keys.t .......... ok
t/zzz_cleanup.t ............ ok
Test Summary Report
-------------------
t/get_public_keys.t      (Wstat: 0 Tests: 3 Failed: 2)
  Failed tests:  2-3
t/get_secret_keys.t      (Wstat: 0 Tests: 2 Failed: 1)
  Failed test:  2
t/list_secret_keys.t     (Wstat: 0 Tests: 4 Failed: 1)
  Failed test:  2
Files=24, Tests=62, 11 wallclock secs ( 0.08 usr  0.04 sys +  6.65 cusr  1.91 csys =  8.68 CPU)
Result: FAIL
gpg-connect-agent: no running gpg-agent - starting '/usr/bin/gpg-agent'
gpg-connect-agent: waiting for the agent to come up ... (5s)
gpg-connect-agent: connection to the agent established
gpg-agent[303]: gpg-agent running and available
subkeys fail comparison; this is a known issue with GnuPG 1.0.1 at t/get_public_keys.t line 212.
gpg: using "0x93AFC4B1B0288A104996B44253AE596EF950DA9C" as default secret key for signing
Failed 3/24 test programs. 4/62 subtests failed.
make: *** [Makefile:801: test_dynamic] Error 255
error: Bad exit status from /var/tmp/rpm-tmp.TEALvJ (%check)


A difference between passing and failing build root is at <https://koschei.fedoraproject.org/build/15468273>. An upgrade of gnupg2 from 2.4.0-3.fc39 to 2.4.1-1.fc39 is suspicious.

Reproducible: Always

Comment 1 Fedora Release Engineering 2023-08-16 08:09:38 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 39 development cycle.
Changing version to 39.

Comment 2 Emmanuel Seyman 2023-09-24 13:22:31 UTC
This has been reported upstream:
https://github.com/bestpractical/gnupg-interface/issues/11

Comment 3 Fedora Update System 2023-12-17 07:46:00 UTC
FEDORA-2023-dee67a7722 has been submitted as an update to Fedora 40. https://bodhi.fedoraproject.org/updates/FEDORA-2023-dee67a7722

Comment 4 Fedora Update System 2023-12-17 07:48:14 UTC
FEDORA-2023-dee67a7722 has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.