Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2208970 - perl-pmtools-2.2.0-17.fc39 FTBFS: t/pmcat.t test fails
Summary: perl-pmtools-2.2.0-17.fc39 FTBFS: t/pmcat.t test fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-pmtools
Version: 38
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F39FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-05-22 08:39 UTC by Petr Pisar
Modified: 2023-06-27 00:35 UTC (History)
3 users (show)

Fixed In Version: perl-pmtools-2.2.0-18.fc39 perl-pmtools-2.2.0-18.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-06-09 01:59:59 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
CPAN 148512 0 None None None 2023-05-31 16:39:27 UTC

Description Petr Pisar 2023-05-22 08:39:28 UTC
perl-pmtools-2.2.0-17.fc39 fails to build in Fedora 39 Koji and Mock because a test fails:

t/pman.t ......... ok
#   Failed test 'pmcat runs'
#   at t/pmcat.t line 18.
#          got: '256'
#     expected: '0'
#   Failed test 'catted Carp'
#   at t/pmcat.t line 19.
#                   ''
#     doesn't match '(?^msx:package\sCarp\;)'
# Looks like you failed 2 tests of 2.
t/pmcat.t ........ 
Dubious, test returned 2 (wstat 512, 0x200)
Failed 2/2 subtests 

A difference between passing and failing build root is at <https://koschei.fedoraproject.org/build/15477718>.


Reproducible: Always

Comment 1 Petr Pisar 2023-05-31 14:51:53 UTC
This can be reduced to:

$ perl -Ilib t/pmcat.t </dev/null
1..2
not ok 1 - pmcat runs
#   Failed test 'pmcat runs'
#   at t/pmcat.t line 18.
#          got: '256'
#     expected: '0'
not ok 2 - catted Carp
#   Failed test 'catted Carp'
#   at t/pmcat.t line 19.
#                   ''
#     doesn't match '(?^msx:package\sCarp\;)'
# Looks like you failed 2 tests of 2.

While having stdin makes the difference:

$ perl -Ilib t/pmcat.t
1..2
ok 1 - pmcat runs
ok 2 - catted Carp

Comment 2 Petr Pisar 2023-05-31 15:09:56 UTC
And reduced to:

$ perl -Ilib bin/pmcat Carp </dev/null >/dev/null; echo $?
1

and then to:

$ /usr/bin/less /usr/share/perl5/vendor_perl/Carp.pm </dev/null >/dev/null; echo $?
1

According to the Koschei report, less was upgraded from 608-2.fc38 to 633-1.fc39.

Comment 3 Fedora Update System 2023-05-31 17:10:03 UTC
FEDORA-2023-e84a5d7bf0 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-e84a5d7bf0

Comment 4 Fedora Update System 2023-06-01 03:16:31 UTC
FEDORA-2023-e84a5d7bf0 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-e84a5d7bf0`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-e84a5d7bf0

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 5 Fedora Update System 2023-06-09 01:59:59 UTC
FEDORA-2023-e84a5d7bf0 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Fedora Update System 2023-06-16 11:45:43 UTC
FEDORA-2023-2428544e3f has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-2428544e3f

Comment 7 Fedora Update System 2023-06-17 02:43:09 UTC
FEDORA-2023-2428544e3f has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-2428544e3f`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-2428544e3f

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2023-06-27 00:35:00 UTC
FEDORA-2023-2428544e3f has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.