Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2210709 - perl-String-License-0.0.4-2.fc39 FTBFS: t/Software-License.t fails for Artistic-1.0-Perl OR GPL-1.0-or-later
Summary: perl-String-License-0.0.4-2.fc39 FTBFS: t/Software-License.t fails for Artist...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-String-License
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Sandro Mani
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: F39FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-05-29 08:51 UTC by Petr Pisar
Modified: 2023-05-30 07:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-05-30 07:16:09 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
CPAN 148479 0 None None None 2023-05-29 08:55:06 UTC

Description Petr Pisar 2023-05-29 08:51:16 UTC
perl-String-License-0.0.4-2.fc39 fails to build in Fedora 39 because a test fails:

# Failed test 'matches expected license for SPDX id Artistic-1.0-Perl OR GPL-1.0-or-later'
# at t/Software-License.t line 97.
# +---------------------------------+----+---------------------------------+
# | GOT                             | OP | CHECK                           |
# +---------------------------------+----+---------------------------------+
# | Artistic-1.0-Perl and/or GPL-1. | eq | Artistic-1.0 and/or GPL-1.0 and |
# | 0 and/or Perl                   |    | /or Perl                        |
# +---------------------------------+----+---------------------------------+
# Seeded srand with seed '20230526' from local date.
t/Software-License.t .. 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/29 subtests 

This is triggered by upgrading perl-Software-License from 0.104002 to 0.104004.

Reproducible: Always

Comment 1 Sandro Mani 2023-05-30 07:16:09 UTC
Fixed in perl-String-License-0.0.4-3.fc39


Note You need to log in before you can comment on or make changes to this bug.