Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2211613 - Missing dependencies make timeline broken
Summary: Missing dependencies make timeline broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernelshark
Version: 38
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Zamir SUN
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-06-01 08:44 UTC by Daniel Bristot de Oliveira
Modified: 2023-06-05 13:49 UTC (History)
3 users (show)

Fixed In Version: kernelshark-2.2.0-3.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-06-05 13:49:31 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Daniel Bristot de Oliveira 2023-06-01 08:44:12 UTC
opening kernelshark is not showing the expected tasks timeline.

Reproducible: Always

Steps to Reproduce:
1. fresh fedora install
2. install kernelshark
3. record a trace with # trace-cmd record -e sched:sched_switch -e sched:sched_wakeup sleep 10
4  open kernelshark
Actual Results:  
broken timeline

Expected Results:  
timeline of CPU & tasks

dnf install gnu-free-fonts-common-20120503-28.fc38.noarch qqc2-desktop-style

fixes it.

Comment 1 Zamir SUN 2023-06-02 08:44:37 UTC
Hi Daniel,

Thanks for the report. Looks like it is not the whole case. I tried on a pretty fresh system and confirm that only install gnu-free-sans-fonts can fix the issue. The display does not change with or without qqc2-desktop-style. I'll push an update as soon as I have some time.

Comment 2 Fedora Update System 2023-06-05 13:48:41 UTC
FEDORA-2023-82de6811d9 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-82de6811d9

Comment 3 Fedora Update System 2023-06-05 13:49:31 UTC
FEDORA-2023-82de6811d9 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.