Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2214541 - rdma-core-46.0-1.fc39 FTBFS: CMake Error at buildlib/RDMA_EnableCStd.cmake:63: Unknown CMake command "CHECK_C_SOURCE_COMPILES"
Summary: rdma-core-46.0-1.fc39 FTBFS: CMake Error at buildlib/RDMA_EnableCStd.cmake:63...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cmake
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Björn 'besser82' Esser
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F39FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-06-13 09:54 UTC by Petr Pisar
Modified: 2023-06-14 06:51 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-06-13 22:09:55 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Petr Pisar 2023-06-13 09:54:37 UTC
rdma-core-46.0-1.fc39 fails to build in Fedora 39:

+ /usr/bin/cmake -S . -B redhat-linux-build -DCMAKE_C_FLAGS_RELEASE:STRING=-DNDEBUG -DCMAKE_CXX_FLAGS_RELEASE:STRING=-DNDEBUG -DCMAKE_Fortran_FLAGS_RELEASE:STRING=-DNDEBUG -DCMAKE_VERBOSE_MAKEFILE:BOOL=ON -DCMAKE_INSTALL_DO_STRIP:BOOL=OFF -DCMAKE_INSTALL_PREFIX:PATH=/usr -DINCLUDE_INSTALL_DIR:PATH=/usr/include -DLIB_INSTALL_DIR:PATH=/usr/lib64 -DSYSCONF_INSTALL_DIR:PATH=/etc -DSHARE_INSTALL_PREFIX:PATH=/usr/share -DLIB_SUFFIX=64 -DBUILD_SHARED_LIBS:BOOL=ON -GNinja -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_BINDIR:PATH=/usr/bin -DCMAKE_INSTALL_SBINDIR:PATH=/usr/sbin -DCMAKE_INSTALL_LIBDIR:PATH=/usr/lib64 -DCMAKE_INSTALL_LIBEXECDIR:PATH=/usr/libexec -DCMAKE_INSTALL_LOCALSTATEDIR:PATH=/var -DCMAKE_INSTALL_SHAREDSTATEDIR:PATH=/var/lib -DCMAKE_INSTALL_INCLUDEDIR:PATH=/usr/include -DCMAKE_INSTALL_INFODIR:PATH=/usr/share/info -DCMAKE_INSTALL_MANDIR:PATH=/usr/share/man -DCMAKE_INSTALL_SYSCONFDIR:PATH=/etc -DCMAKE_INSTALL_SYSTEMD_SERVICEDIR:PATH=/usr/lib/systemd/system -DCMAKE_INSTALL_INITDDIR:PATH=/etc/rc.d/init.d -DCMAKE_INSTALL_RUNDIR:PATH=/run -DCMAKE_INSTALL_DOCDIR:PATH=/usr/share/doc/rdma-core -DCMAKE_INSTALL_UDEV_RULESDIR:PATH=/usr/lib/udev/rules.d -DCMAKE_INSTALL_PERLDIR:PATH=/usr/share/perl5/vendor_perl -DENABLE_IBDIAGS_COMPAT:BOOL=True -DPYTHON_EXECUTABLE:PATH=/usr/bin/python3 -DCMAKE_INSTALL_PYTHON_ARCH_LIB:PATH=/usr/lib64/python3.11/site-packages -DNO_PYVERBS=0
-- The C compiler identification is GNU 13.1.1
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working C compiler: /usr/bin/gcc - skipped
-- Detecting C compile features
-- Detecting C compile features - done
CMake Error at buildlib/RDMA_EnableCStd.cmake:63 (CHECK_C_SOURCE_COMPILES):
  Unknown CMake command "CHECK_C_SOURCE_COMPILES".
Call Stack (most recent call first):
  CMakeLists.txt:209 (RDMA_Check_C_Compiles)
-- Configuring incomplete, errors occurred!

A difference between passing and failing build root is at <https://koschei.fedoraproject.org/build/15603625>. An upgrade of cmake from 3.26.4-4.fc39 to 3.27.0~rc1-1.fc39 looks suspicious.

Reproducible: Always

Comment 1 Petr Pisar 2023-06-13 10:00:46 UTC
See <https://gitlab.kitware.com/cmake/cmake/-/issues/24991>.

Comment 2 Michael Catanzaro 2023-06-13 14:11:25 UTC
I cannot build WebKitGTK either.

Comment 3 Michael Catanzaro 2023-06-13 14:12:33 UTC
Looks like this is already fixed by https://bodhi.fedoraproject.org/updates/FEDORA-2023-e1605f6cba and we just need to wait for it to reach the buildroot.

Comment 4 Michael Catanzaro 2023-06-13 22:09:55 UTC
Fixed now

Comment 5 Michal Schmidt 2023-06-14 06:51:37 UTC
I filed a PR for rdma-core upstream to add the missing CMake module include:
https://github.com/linux-rdma/rdma-core/pull/1350


Note You need to log in before you can comment on or make changes to this bug.