Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2220045 - F39FailsToInstall: mu
Summary: F39FailsToInstall: mu
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: mu
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 2220131 2220224 2220367 2220424 2220495 2220613
Blocks: F39FTBFS F39FailsToInstall PYTHON3.12
TreeView+ depends on / blocked
 
Reported: 2023-07-05 19:05 UTC by Fedora Fails To Install
Modified: 2023-07-27 17:06 UTC (History)
3 users (show)

Fixed In Version: mu-1.2.0-3.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-07-27 17:06:48 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Fails To Install 2023-07-05 19:05:50 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (mu) Fails To Install in Fedora 39:

can't install mu:
  - nothing provides (python3.11dist(platformdirs) < 4~~ with python3.11dist(platformdirs) >= 2) needed by mu-1.2.0-2.fc39.noarch
  - nothing provides python3.11dist(pyserial) >= 3.4 needed by mu-1.2.0-2.fc39.noarch
  - nothing provides (python3.11dist(adafruit-board-toolkit) >= 1.1 with python3.11dist(adafruit-board-toolkit) < 2) needed by mu-1.2.0-2.fc39.noarch
  - nothing provides (python3.11dist(flask) >= 2 with python3.11dist(flask) < 3) needed by mu-1.2.0-2.fc39.noarch
  - nothing provides (python3.11dist(pyqtchart) < 6~~ with python3.11dist(pyqtchart) >= 5.13.1) needed by mu-1.2.0-2.fc39.noarch
  - nothing provides (python3.11dist(qtconsole) < 6~~ with python3.11dist(qtconsole) >= 4.7.7) needed by mu-1.2.0-2.fc39.noarch
  - nothing provides python3.11dist(esptool) >= 3 needed by mu-1.2.0-2.fc39.noarch
  - nothing provides python3.11dist(ipykernel) >= 4.1 needed by mu-1.2.0-2.fc39.noarch
  - nothing provides python3.11dist(ipython-genutils) >= 0.2 needed by mu-1.2.0-2.fc39.noarch
  - nothing provides python3.11dist(jupyter-client) >= 4.1 needed by mu-1.2.0-2.fc39.noarch
  - nothing provides python3.11dist(microfs) >= 1.3 needed by mu-1.2.0-2.fc39.noarch
  - nothing provides python3.11dist(pgzero) >= 1.2.1 needed by mu-1.2.0-2.fc39.noarch
  - nothing provides python3.11dist(pyqt5) >= 5.13.2 needed by mu-1.2.0-2.fc39.noarch
  - nothing provides python3.11dist(qscintilla) >= 2.11.3 needed by mu-1.2.0-2.fc39.noarch
  - nothing provides python3.11dist(virtualenv) >= 20 needed by mu-1.2.0-2.fc39.noarch
  - nothing provides python3.11dist(click) needed by mu-1.2.0-2.fc39.noarch
  - nothing provides python3.11dist(wheel) needed by mu-1.2.0-2.fc39.noarch
  - nothing provides python(abi) = 3.11 needed by mu-1.2.0-2.fc39.noarch
  - nothing provides python3.11dist(requests) >= 2 needed by mu-1.2.0-2.fc39.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-39-x86_64 --config-opts mirrored=False install mu


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2023-07-25 23:31:10 UTC
=========== 9 failed, 1105 passed, 21 skipped, 7 warnings in 20.42s ============


3 times:

E               AttributeError: 'called_once_with' is not a valid assertion. Use a spec for the mock if 'called_once_with' is meant to be an attribute.. Did you mean: 'assert_called_once_with'?


5 times:

E               AttributeError: 'called_with' is not a valid assertion. Use a spec for the mock if 'called_with' is meant to be an attribute.

1 times:

E               AttributeError: 'called_once' is not a valid assertion. Use a spec for the mock if 'called_once' is meant to be an attribute.


-----

All should be fixable.


Note You need to log in before you can comment on or make changes to this bug.