Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2220255 - F39FailsToInstall: python3-glymur
Summary: F39FailsToInstall: python3-glymur
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-glymur
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ben Beasley
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: F39FTBFS F39FailsToInstall PYTHON3.12
TreeView+ depends on / blocked
 
Reported: 2023-07-05 19:12 UTC by Fedora Fails To Install
Modified: 2023-07-11 20:54 UTC (History)
5 users (show)

Fixed In Version: python-glymur-0.12.7-3.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-07-11 20:54:55 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github quintusdias glymur pull 621 0 None open Adapt to OrderedDict repr change in Python 3.12 2023-07-11 20:33:17 UTC

Description Fedora Fails To Install 2023-07-05 19:12:52 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (python-glymur) Fails To Install in Fedora 39:

can't install python3-glymur:
  - nothing provides python3.11dist(numpy) needed by python3-glymur-0.12.7-1.fc39.noarch
  - nothing provides python3.11dist(packaging) needed by python3-glymur-0.12.7-1.fc39.noarch
  - nothing provides python3.11dist(lxml) needed by python3-glymur-0.12.7-1.fc39.noarch
  - nothing provides python(abi) = 3.11 needed by python3-glymur-0.12.7-1.fc39.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-39-x86_64 --config-opts mirrored=False install python3-glymur


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2023-07-11 20:04:05 UTC
=================================== FAILURES ===================================
_________________________ TestPrinting.test_exif_uuid __________________________
self = <tests.test_printing.TestPrinting testMethod=test_exif_uuid>
    def test_exif_uuid(self):
        """
        SCENARIO:  A JP2 file has an Exif UUID box.
    
        EXPECTED RESULT:  Verify printing of Exif information.
        """
        with open(self.temp_jp2_filename, mode='wb') as tfile:
    
            with open(self.jp2file, 'rb') as ifptr:
                tfile.write(ifptr.read())
    
            b = BytesIO()
    
            # UUID stuff at byte 0
            # Exif leader at byte 24
            # TIFF header at byte 30
            # IFD start at byte 38
            # IFD tags at byte 40
            # tile offsets at byte 88 (40 bytes)
            #    IFD location 58
            # Exif IFD start at byte 128
            #    IFD byte location 98
            # Exif IFD tag at byte 130 (12 bytes)
    
            # Write L, T, UUID identifier.
            b.write(struct.pack('>I4s', 142, b'uuid'))
            b.write(b'JpgTiffExif->JP2')
    
            b.write(b'Exif\x00\x00')
    
            # write the tiff header
            xbuffer = struct.pack('<BBHI', 73, 73, 42, 8)
            b.write(xbuffer)
    
            # We will write just four tags.
            b.write(struct.pack('<H', 4))
    
            # The "Make" tag is tag no. 271.
            b.write(struct.pack('<HHII', 256, 4, 1, 256))
            b.write(struct.pack('<HHII', 257, 4, 1, 512))
    
            b.write(struct.pack('<HHII', 324, 4, 10, 58))
    
            b.write(struct.pack('<HHII', 34665, 4, 1, 98))
    
            # write the tile offsets (fake)
            tile_offsets = list(range(0, 100, 10))
            b.write(struct.pack('<' + 'I' * 10, *tile_offsets))
    
            # start writing the Exif IFD.
    
            # We will write just one tag.
            b.write(struct.pack('<H', 1))
    
            b.write(struct.pack('<HHI4s', 271, 2, 3, b'HTC\x00'))
            b.flush()
    
            tfile.write(b.getvalue())
            tfile.flush()
    
            j = glymur.Jp2k(tfile.name)
    
            actual = str(j.box[5])
    
        expected = (
            "UUID Box (uuid) @ (1135519, 142)\n"
            "    UUID:  4a706754-6966-6645-7869-662d3e4a5032 (EXIF)\n"
            "    UUID Data:  OrderedDict([   ('ImageWidth', 256),\n"
            "                    ('ImageLength', 512),\n"
            "                    (   'TileOffsets',\n"
            "                        "
            "array([ 0, 10, 20, ..., 70, 80, 90], dtype=uint32)),\n"
            "                    ('ExifTag', OrderedDict([('Make', 'HTC')]))])"
        )
>       self.assertEqual(actual, expected)
E       AssertionError: "UUID[304 chars]                 ('ExifTag', OrderedDict({'Make': 'HTC'}))])" != "UUID[304 chars]                 ('ExifTag', OrderedDict([('Make', 'HTC')]))])"
E         UUID Box (uuid) @ (1135519, 142)
E             UUID:  4a706754-6966-6645-7869-662d3e4a5032 (EXIF)
E             UUID Data:  OrderedDict([   ('ImageWidth', 256),
E                             ('ImageLength', 512),
E                             (   'TileOffsets',
E                                 array([ 0, 10, 20, ..., 70, 80, 90], dtype=uint32)),
E       -                     ('ExifTag', OrderedDict({'Make': 'HTC'}))])
E       ?                                             ^      ^      ^
E       +                     ('ExifTag', OrderedDict([('Make', 'HTC')]))])
E       ?                                             ^^      ^      ^^
tests/test_printing.py:1071: AssertionError
=========================== short test summary info ============================
FAILED tests/test_printing.py::TestPrinting::test_exif_uuid - AssertionError:...
================== 1 failed, 605 passed, 1 skipped in 51.41s ===================



Caused by https://github.com/python/cpython/pull/101661

Comment 2 Ben Beasley 2023-07-11 20:33:17 UTC
This looks like a

Comment 3 Ben Beasley 2023-07-11 20:34:21 UTC
(In reply to Ben Beasley from comment #2)
> This looks like a

Abandonded comment, sorry. But I’ve proposed a workaround upstream and am working on a downstream build now.

Comment 4 Fedora Update System 2023-07-11 20:52:18 UTC
FEDORA-2023-2e5625c158 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-2e5625c158

Comment 5 Fedora Update System 2023-07-11 20:54:55 UTC
FEDORA-2023-2e5625c158 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.