Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2220472 - F39FailsToInstall: python3-qdarkstyle
Summary: F39FailsToInstall: python3-qdarkstyle
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-qdarkstyle
Version: 39
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ben Beasley
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2226310 (view as bug list)
Depends On: 2220310 2220317 2220332 2220441 2220444 2220452
Blocks: F39FTBFS F39FailsToInstall F40FailsToInstall F40FTBFS PYTHON3.12 2219983 2220598 2225768
TreeView+ depends on / blocked
 
Reported: 2023-07-05 19:19 UTC by Fedora Fails To Install
Modified: 2023-09-27 01:32 UTC (History)
4 users (show)

Fixed In Version: python-qdarkstyle-3.0.2-10.fc40 python-qdarkstyle-3.0.3-4.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-27 01:32:45 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Fails To Install 2023-07-05 19:19:54 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (python-qdarkstyle) Fails To Install in Fedora 39:

can't install python3-qdarkstyle:
  - nothing provides python(abi) = 3.11 needed by python3-qdarkstyle-3.0.2-7.fc38.noarch
  - nothing provides python3.11dist(qtpy) >= 1.9 needed by python3-qdarkstyle-3.0.2-7.fc38.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-39-x86_64 --config-opts mirrored=False install python3-qdarkstyle


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Fedora Fails To Install 2023-07-13 11:58:33 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

This package fails to install and maintainers are advised to take one of the following actions:

 - Fix this bug and close this bugzilla once the update makes it to the repository.
   (The same script that posted this comment will eventually close this bugzilla
   when the fixed package reaches the repository, so you don't have to worry about it.)

or

 - Move this bug to ASSIGNED if you plan on fixing this, but simply haven't done so yet.

or

 - Orphan the package if you no longer plan to maintain it.


If you do not take one of these actions, the process at https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs will continue.
This package may be orphaned in 7+ weeks.
This is the first reminder (step 3) from the policy.

Don't hesitate to ask for help on devel.org if you are unsure how to fix this bug.

Comment 2 Fedora Fails To Install 2023-08-05 09:29:24 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

This package fails to install and maintainers are advised to take one of the following actions:

 - Fix this bug and close this bugzilla once the update makes it to the repository.
   (The same script that posted this comment will eventually close this bugzilla
   when the fixed package reaches the repository, so you don't have to worry about it.)

or

 - Move this bug to ASSIGNED if you plan on fixing this, but simply haven't done so yet.

or

 - Orphan the package if you no longer plan to maintain it.


If you do not take one of these actions, the process at https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs will continue.
This package may be orphaned in 4+ weeks.
This is the second reminder (step 4) from the policy.

Don't hesitate to ask for help on https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/ if you are unsure how to fix this bug.

Comment 3 Mukundan Ragavan 2023-08-13 22:06:16 UTC
*** Bug 2226310 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Release Engineering 2023-08-16 07:17:49 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 39 development cycle.
Changing version to 39.

Comment 6 Fedora Admin user for bugzilla script actions 2023-08-16 12:55:40 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 7 Fedora Fails To Install 2023-08-17 13:47:34 UTC
This package has been orphaned.

You can pick it up at https://src.fedoraproject.org/rpms/python-qdarkstyle by clicking button "Take". If nobody picks it up, it will be retired and removed from a distribution.

Comment 8 Adam Williamson 2023-08-29 18:51:47 UTC
Note this depends on pyside2, which is also FTBFS for 3.12 and looks like a big project.

Comment 9 Ben Beasley 2023-09-14 13:49:12 UTC
I’ve just taken this orphaned package (along with its dependencies python-libsass and python-qtsass) in order to help with the effort to keep Spyder in the distribution.

I plan to fully audit the package and modernize its packaging in the next few days, along with getting python-libsass and python-libsass fully updated in at least Rawhide.

For now, it looks like this package can be fixed in F39/F40 by supporting only PyQt5, dropping support for PySide2, which is badly broken with Python 3.12 (bug 2155447, bug 2149820, bug 2220452, bug 2226300).

Comment 10 Fedora Update System 2023-09-14 13:59:15 UTC
FEDORA-2023-e3704afa74 has been submitted as an update to Fedora 40. https://bodhi.fedoraproject.org/updates/FEDORA-2023-e3704afa74

Comment 11 Fedora Update System 2023-09-14 14:01:37 UTC
FEDORA-2023-e3704afa74 has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 12 Fedora Update System 2023-09-14 14:27:44 UTC
FEDORA-2023-f23af1c90c has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-f23af1c90c

Comment 13 Fedora Update System 2023-09-15 02:28:24 UTC
FEDORA-2023-f23af1c90c has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-f23af1c90c`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-f23af1c90c

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 14 Fedora Update System 2023-09-18 15:51:27 UTC
FEDORA-2023-527f01eddb has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-527f01eddb

Comment 15 Fedora Update System 2023-09-19 01:11:25 UTC
FEDORA-2023-527f01eddb has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-527f01eddb`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-527f01eddb

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2023-09-27 01:32:45 UTC
FEDORA-2023-527f01eddb has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.