Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2220488 - F39FailsToInstall: rust-update-set
Summary: F39FailsToInstall: rust-update-set
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-rust-update-set
Version: 39
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Michel Lind
QA Contact:
URL:
Whiteboard:
: 2226322 (view as bug list)
Depends On: 2226322
Blocks: F39FTBFS F39FailsToInstall F40FailsToInstall F40FTBFS PYTHON3.12
TreeView+ depends on / blocked
 
Reported: 2023-07-05 19:20 UTC by Fedora Fails To Install
Modified: 2023-09-29 00:19 UTC (History)
4 users (show)

Fixed In Version: python-rust-update-set-0.0.1-5.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-29 00:19:33 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Fails To Install 2023-07-05 19:20:30 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (python-rust-update-set) Fails To Install in Fedora 39:

can't install rust-update-set:
  - nothing provides python3.11dist(requests) needed by rust-update-set-0.0.1-2.fc38.noarch
  - nothing provides python3.11dist(bodhi-client) needed by rust-update-set-0.0.1-2.fc38.noarch
  - nothing provides python3.11dist(rust2rpm) needed by rust-update-set-0.0.1-2.fc38.noarch
  - nothing provides python(abi) = 3.11 needed by rust-update-set-0.0.1-2.fc38.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-39-x86_64 --config-opts mirrored=False install rust-update-set


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Fedora Fails To Install 2023-07-13 11:58:55 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

This package fails to install and maintainers are advised to take one of the following actions:

 - Fix this bug and close this bugzilla once the update makes it to the repository.
   (The same script that posted this comment will eventually close this bugzilla
   when the fixed package reaches the repository, so you don't have to worry about it.)

or

 - Move this bug to ASSIGNED if you plan on fixing this, but simply haven't done so yet.

or

 - Orphan the package if you no longer plan to maintain it.


If you do not take one of these actions, the process at https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs will continue.
This package may be orphaned in 7+ weeks.
This is the first reminder (step 3) from the policy.

Don't hesitate to ask for help on devel.org if you are unsure how to fix this bug.

Comment 2 Fedora Release Engineering 2023-08-16 07:17:54 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 39 development cycle.
Changing version to 39.

Comment 3 Miro Hrončok 2023-09-21 09:33:44 UTC
Michel, I see you assigned this bugzilla almost 2 months ago. Have you made any progress?

The package fails to install and fails to build. Fedora 39 Beta was just released. Is it probable that this will be fixed (or worked around) in time for the Fedora 39 Final Freeze (2023-10-03)? If not, could you please consider retiring the package, so we can obsolete it and unblock clean upgrades to Fedora 39? A retired package can be reintroduced later during the lifetime of Fedora 39.

Comment 4 Miro Hrončok 2023-09-21 09:34:11 UTC
*** Bug 2226322 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2023-09-27 11:19:26 UTC
FEDORA-2023-dfe9c0f49e has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-dfe9c0f49e

Comment 7 Fedora Update System 2023-09-28 20:17:04 UTC
FEDORA-2023-dfe9c0f49e has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-dfe9c0f49e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-dfe9c0f49e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2023-09-29 00:19:33 UTC
FEDORA-2023-dfe9c0f49e has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.