Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2220511 - F39FailsToInstall: python3-social-auth-core+openidconnect, python3-social-auth-core
Summary: F39FailsToInstall: python3-social-auth-core+openidconnect, python3-social-aut...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-social-auth-core
Version: 39
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: cqi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2226337 (view as bug list)
Depends On: 2220581
Blocks: F39FTBFS F39FailsToInstall F40FailsToInstall F40FTBFS PYTHON3.12
TreeView+ depends on / blocked
 
Reported: 2023-07-05 19:21 UTC by Fedora Fails To Install
Modified: 2023-08-19 11:48 UTC (History)
3 users (show)

Fixed In Version: python-social-auth-core-4.3.0-6.fc40, python-social-auth-core-4.3.0-6.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-08-19 11:48:21 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Fails To Install 2023-07-05 19:21:34 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (python-social-auth-core) Fails To Install in Fedora 39:

can't install python3-social-auth-core+openidconnect:
  - nothing provides python(abi) = 3.11 needed by python3-social-auth-core+openidconnect-4.3.0-5.fc38.noarch
  - nothing provides python3.11dist(python-jose) >= 3 needed by python3-social-auth-core+openidconnect-4.3.0-5.fc38.noarch
  
can't install python3-social-auth-core:
  - nothing provides python(abi) = 3.11 needed by python3-social-auth-core-4.3.0-5.fc38.noarch
  - nothing provides python3.11dist(cryptography) >= 1.4 needed by python3-social-auth-core-4.3.0-5.fc38.noarch
  - nothing provides python3.11dist(pyjwt) >= 2 needed by python3-social-auth-core-4.3.0-5.fc38.noarch
  - nothing provides python3.11dist(defusedxml) >= 0.5~rc1 needed by python3-social-auth-core-4.3.0-5.fc38.noarch
  - nothing provides python3.11dist(oauthlib) >= 1.0.3 needed by python3-social-auth-core-4.3.0-5.fc38.noarch
  - nothing provides python3.11dist(python3-openid) >= 3.0.10 needed by python3-social-auth-core-4.3.0-5.fc38.noarch
  - nothing provides python3.11dist(requests) >= 2.9.1 needed by python3-social-auth-core-4.3.0-5.fc38.noarch
  - nothing provides python3.11dist(requests-oauthlib) >= 0.6.1 needed by python3-social-auth-core-4.3.0-5.fc38.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-39-x86_64 --config-opts mirrored=False install python3-social-auth-core+openidconnect python3-social-auth-core


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Fedora Fails To Install 2023-07-13 11:59:35 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

This package fails to install and maintainers are advised to take one of the following actions:

 - Fix this bug and close this bugzilla once the update makes it to the repository.
   (The same script that posted this comment will eventually close this bugzilla
   when the fixed package reaches the repository, so you don't have to worry about it.)

or

 - Move this bug to ASSIGNED if you plan on fixing this, but simply haven't done so yet.

or

 - Orphan the package if you no longer plan to maintain it.


If you do not take one of these actions, the process at https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs will continue.
This package may be orphaned in 7+ weeks.
This is the first reminder (step 3) from the policy.

Don't hesitate to ask for help on devel.org if you are unsure how to fix this bug.

Comment 2 cqi 2023-07-13 12:31:39 UTC
podman run --rm -it registry.fedoraproject.org/fedora:39
[root@af8764de6e24 /]# dnf search python3-saml
Updating and loading repositories:
 Fedora - Rawhide - Developmental packages for the next Fedora release                          100% | 174.2 KiB/s |  22.7 MiB |  02m13s
 Fedora rawhide openh264 (From Cisco) - x86_64                                                  100% |   2.6 KiB/s |   5.1 KiB |  00m02s
Repositories loaded.
Matched fields: name (exact)
 python3-saml.noarch: Add SAML support to your Python software using this library
[root@af8764de6e24 /]# dnf install python3-saml
Updating and loading repositories:
Repositories loaded.
Failed to resolve the transaction:
Problem: conflicting requests
  - nothing provides python(abi) = 3.11 needed by python3-saml-1.11.0-4.fc37.noarch
  - nothing provides python3.11dist(lxml) >= 3.3.5 needed by python3-saml-1.11.0-4.fc37.noarch
  - nothing provides python3.11dist(isodate) >= 0.5 needed by python3-saml-1.11.0-4.fc37.noarch
  - nothing provides python3.11dist(xmlsec) >= 1.0.5 needed by python3-saml-1.11.0-4.fc37.noarch

[root@af8764de6e24 /]# dnf info python3-saml
Updating and loading repositories:
Repositories loaded.
Available packages
Name           : python3-saml
Epoch          : 0
Version        : 1.11.0
Release        : 4.fc37
Architecture   : noarch
Download size  : 164.2 KiB
Installed size : 791.2 KiB
Source         : python3-saml-1.11.0-4.fc37.src.rpm
Repository     : rawhide
Summary        : Add SAML support to your Python software using this library
URL            : https://pypi.python.org/pypi/python3-saml
License        : MIT
Description    : This toolkit lets you turn your Python application into a SP
               : (Service Provider) that can be connected to an IdP (Identity Provider).

Can't install python3-saml for now. An old version is included in f39 image. BTW, registry.fedoraproject.org/fedora:39 is pulled just before running above container.

Comment 3 Fedora Fails To Install 2023-08-05 09:29:58 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

This package fails to install and maintainers are advised to take one of the following actions:

 - Fix this bug and close this bugzilla once the update makes it to the repository.
   (The same script that posted this comment will eventually close this bugzilla
   when the fixed package reaches the repository, so you don't have to worry about it.)

or

 - Move this bug to ASSIGNED if you plan on fixing this, but simply haven't done so yet.

or

 - Orphan the package if you no longer plan to maintain it.


If you do not take one of these actions, the process at https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs will continue.
This package may be orphaned in 4+ weeks.
This is the second reminder (step 4) from the policy.

Don't hesitate to ask for help on https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/ if you are unsure how to fix this bug.

Comment 4 cqi 2023-08-09 02:26:37 UTC
Any idea about https://bugzilla.redhat.com/show_bug.cgi?id=2220511#c2 ?

Comment 5 Fedora Release Engineering 2023-08-16 07:18:07 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 39 development cycle.
Changing version to 39.

Comment 6 Miro Hrončok 2023-08-19 11:36:50 UTC
saml has been fixed, attempting a build.

Comment 7 Miro Hrončok 2023-08-19 11:36:59 UTC
*** Bug 2226337 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.