Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2220583 - pythran fails to build without distutils and hence fails to install with Python 3.12
Summary: pythran fails to build without distutils and hence fails to install with Pyth...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: pythran
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miro Hrončok
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 2192436
Blocks: F39FTBFS F39FailsToInstall PYTHON3.12 2220492 2220593
TreeView+ depends on / blocked
 
Reported: 2023-07-05 19:23 UTC by Fedora Fails To Install
Modified: 2023-07-10 12:26 UTC (History)
4 users (show)

Fixed In Version: pythran-0.13.1-1.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-07-10 12:26:46 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github serge-sans-paille pythran issues 2121 0 None open Test failures with Python 3.12 2023-07-07 08:07:01 UTC

Description Fedora Fails To Install 2023-07-05 19:23:53 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (pythran) Fails To Install in Fedora 39:

can't install pythran:
  - nothing provides (python3.11dist(beniget) >= 0.4 with python3.11dist(beniget) < 0.5) needed by pythran-0.12.1-2.fc38.x86_64
  - nothing provides (python3.11dist(gast) >= 0.5 with python3.11dist(gast) < 0.6) needed by pythran-0.12.1-2.fc38.x86_64
  - nothing provides python3.11dist(ply) >= 3.4 needed by pythran-0.12.1-2.fc38.x86_64
  - nothing provides python3.11dist(numpy) needed by pythran-0.12.1-2.fc38.x86_64
  - nothing provides python(abi) = 3.11 needed by pythran-0.12.1-2.fc38.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-39-x86_64 --config-opts mirrored=False install pythran


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Ben Beasley 2023-07-05 20:23:51 UTC
It looks like the dependencies are OK, and pythran test failures in the Python 3.12 mass rebuild are the primary cause here.

Related:

MNT: do not use the deprecated imp module
https://github.com/serge-sans-paille/pythran/commit/453da74eb2de73474d6c955c775e0f37ac9ccd21

Only use numpy.distutils conditionally
https://github.com/serge-sans-paille/pythran/commit/cd68ac68678f1c194d5f824564d43ae7664bd061

Since both of those are in release 0.13.1, it seems likely that updating to that release may fix the Python 3.12 FTBFS. At minimum, it should improve the situation.

Comment 2 Miro Hrončok 2023-07-06 07:40:34 UTC
Related WIP PR: https://src.fedoraproject.org/rpms/pythran/pull-request/25

Comment 3 Miro Hrončok 2023-07-07 08:07:02 UTC
Upstream issue https://github.com/serge-sans-paille/pythran/issues/2121


Note You need to log in before you can comment on or make changes to this bug.