Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2221215 - ipython: FTBFS in Fedora Rawhide
Summary: ipython: FTBFS in Fedora Rawhide
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ipython
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Lumír Balhar
QA Contact: Fedora Extras Quality Assurance
URL: https://koji.fedoraproject.org/koji/b...
Whiteboard:
Depends On:
Blocks: F39FTBFS PYTHON3.12 2220285
TreeView+ depends on / blocked
 
Reported: 2023-07-07 14:07 UTC by Mattias Ellert
Modified: 2023-07-11 10:45 UTC (History)
8 users (show)

Fixed In Version: ipython-8.14.0-4.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-07-11 10:45:55 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Mattias Ellert 2023-07-07 14:07:09 UTC
Description of problem:
Package ipython fails to build from source in Fedora Rawhide.

Version-Release number of selected component (if applicable):
8.14.0-3.fc39

Steps to Reproduce:
koji build --scratch f39 ipython-8.14.0-3.fc39.src.rpm

Additional info:
During the Python 3.12 update, only the bootstrap build (ipython-8.14.0-2.fc39) was successful. The complete build (ipython-8.14.0-3.fc39) failed.

The bootstrap build does not build the python3-ipython+test sub-package. Since the last successful build was the bootstrap build, other packages that requires python3-ipython+test are not installable.

Reproducible: Always

Steps to Reproduce:
1. Rebuild package in rawhide

Actual Results:  
Build fails

Expected Results:  
Build succeeds

Comment 1 Miro Hrončok 2023-07-10 22:23:13 UTC
=========================== short test summary info ============================
FAILED core/tests/test_inputsplitter.py::InputSplitterTestCase::test_check_complete
FAILED core/tests/test_inputsplitter.py::InputSplitterTestCase::test_line_continuation
FAILED core/tests/test_inputsplitter.py::IPythonInputTestCase::test_line_continuation
FAILED core/tests/test_inputsplitter.py::test_find_next_indent - AssertionErr...
FAILED core/tests/test_inputtransformer2.py::test_check_make_token_by_line_never_ends_empty
FAILED core/tests/test_inputtransformer2.py::test_find_assign_system - Attrib...
FAILED core/tests/test_inputtransformer2.py::test_check_complete_param[(\n))-incomplete-0]
FAILED core/tests/test_inputtransformer2.py::test_check_complete_param[a \\ -invalid-None]
FAILED core/tests/test_inputtransformer2.py::test_check_complete - AssertionE...
FAILED core/tests/test_interactiveshell.py::InteractiveShellTestCase::test_var_expand_local
FAILED core/tests/test_interactiveshell.py::InteractiveShellTestCase::test_var_expand_self
FAILED utils/tests/test_pycolorize.py::test_parse_sample[Linux] - assert 'ERR...
FAILED utils/tests/test_pycolorize.py::test_parse_error[Linux] - AssertionErr...
FAILED utils/tests/test_pycolorize.py::test_parse_sample[LightBG] - assert 'E...
FAILED utils/tests/test_pycolorize.py::test_parse_error[LightBG] - AssertionE...
FAILED utils/tests/test_pycolorize.py::test_parse_sample[Neutral] - assert 'E...
FAILED utils/tests/test_pycolorize.py::test_parse_error[Neutral] - AssertionE...
==== 17 failed, 1231 passed, 33 skipped, 1 xpassed, 116 warnings in 58.77s =====

Comment 2 Fedora Update System 2023-07-11 10:44:57 UTC
FEDORA-2023-5ad68d9635 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-5ad68d9635

Comment 3 Fedora Update System 2023-07-11 10:45:55 UTC
FEDORA-2023-5ad68d9635 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.