Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2221454 - F39FailsToInstall: breeze-icon-theme-devel
Summary: F39FailsToInstall: breeze-icon-theme-devel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: breeze-icon-theme
Version: 39
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Neal Gompa
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: AcceptedFreezeException
: 2239862 2239864 (view as bug list)
Depends On:
Blocks: F39FailsToInstall F39FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2023-07-09 07:19 UTC by Fedora Fails To Install
Modified: 2023-10-07 03:23 UTC (History)
6 users (show)

Fixed In Version: breeze-icon-theme-5.110.0-2.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-10-07 03:23:41 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Fedora Fails To Install 2023-07-09 07:19:24 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (breeze-icon-theme) Fails To Install in Fedora 39:

can't install breeze-icon-theme-devel:
  - nothing provides cmake-filesystem(aarch-64) needed by breeze-icon-theme-devel-5.108.0-1.fc39.noarch
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-39-x86_64 --config-opts mirrored=False install breeze-icon-theme-devel


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Miro Hrončok 2023-07-09 07:22:21 UTC
A noarch package cannot use %{?_isa} in Requires:

    Requires:    %{name}%{?_isa} = %{version}-%{release}

Comment 2 Fedora Fails To Install 2023-07-17 07:29:50 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

This package fails to install and maintainers are advised to take one of the following actions:

 - Fix this bug and close this bugzilla once the update makes it to the repository.
   (The same script that posted this comment will eventually close this bugzilla
   when the fixed package reaches the repository, so you don't have to worry about it.)

or

 - Move this bug to ASSIGNED if you plan on fixing this, but simply haven't done so yet.

or

 - Orphan the package if you no longer plan to maintain it.


If you do not take one of these actions, the process at https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs will continue.
This package may be orphaned in 7+ weeks.
This is the first reminder (step 3) from the policy.

Don't hesitate to ask for help on devel.org if you are unsure how to fix this bug.

Comment 3 Fedora Fails To Install 2023-08-08 08:18:07 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

This package fails to install and maintainers are advised to take one of the following actions:

 - Fix this bug and close this bugzilla once the update makes it to the repository.
   (The same script that posted this comment will eventually close this bugzilla
   when the fixed package reaches the repository, so you don't have to worry about it.)

or

 - Move this bug to ASSIGNED if you plan on fixing this, but simply haven't done so yet.

or

 - Orphan the package if you no longer plan to maintain it.


If you do not take one of these actions, the process at https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs will continue.
This package may be orphaned in 4+ weeks.
This is the second reminder (step 4) from the policy.

Don't hesitate to ask for help on https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/ if you are unsure how to fix this bug.

Comment 4 Fedora Release Engineering 2023-08-16 07:18:53 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 39 development cycle.
Changing version to 39.

Comment 5 Fedora Admin user for bugzilla script actions 2023-09-08 12:10:21 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 6 Fedora Fails To Install 2023-09-12 10:38:20 UTC
This package has been orphaned.

You can pick it up at https://src.fedoraproject.org/rpms/breeze-icon-theme by clicking button "Take". If nobody picks it up, it will be retired and removed from a distribution.

Comment 8 Miro Hrončok 2023-09-20 14:46:47 UTC
That commit does not fix the requirement of arched cmake-filesystem (which is presumably autogenerated).

Comment 9 Miro Hrončok 2023-09-20 14:47:22 UTC
*** Bug 2239864 has been marked as a duplicate of this bug. ***

Comment 10 Miro Hrončok 2023-09-20 14:47:24 UTC
*** Bug 2239862 has been marked as a duplicate of this bug. ***

Comment 11 Fedora Fails To Install 2023-09-21 09:59:13 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

This package fails to install and maintainers are advised to take one of the following actions:

 - Fix this bug and close this bugzilla once the update makes it to the repository.
   (The same script that posted this comment will eventually close this bugzilla
   when the fixed package reaches the repository, so you don't have to worry about it.)

or

 - Move this bug to ASSIGNED if you plan on fixing this, but simply haven't done so yet.

or

 - Orphan the package if you no longer plan to maintain it.


If you do not take one of these actions, the process at https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs will continue.
This package may be orphaned in 7+ weeks.
This is the first reminder (step 3) from the policy.

Don't hesitate to ask for help on https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/ if you are unsure how to fix this bug.

Comment 12 Miro Hrončok 2023-09-23 18:31:51 UTC
This package is listed in https://pagure.io/releng/issue/11685 and it will be retired in 3 days if not at least ASSIGNED.

Comment 13 Neal Gompa 2023-09-23 18:46:54 UTC
I don't know how I'm supposed to fix this, since this is the responsibility of the CMake generator, which already does the right thing for noarch packages: https://src.fedoraproject.org/rpms/cmake/blob/rawhide/f/cmake.req#_49-53

But sure, I guess we'll figure out what to do.

Comment 14 Miro Hrončok 2023-09-23 18:57:47 UTC
I think the location of the cmake files is key -- %{_kf5_libdir}/cmake is likely classified as a location for architecture-specific files

Examples:

cli11-devel.noarch requires cmake-filesystem -- it has files in %{_datadir}/cmake/CLI11
eigen3-devel.noarch requires cmake-filesystem -- it has files in %{_datadir}/cmake/eigen3
assimp-devel.x86_64 requires cmake-filesystem(x86-64) -- it has files in %{_libdir}/cmake/assimp-5.0

Comment 15 Miro Hrončok 2023-09-23 18:58:53 UTC
https://src.fedoraproject.org/rpms/cmake/blob/rawhide/f/cmake.req#_46-47

                if re.match(".*/usr/lib(64)?/cmake/.*", modulePath):
                    is_arched = True

Comment 16 Neal Gompa 2023-09-25 00:12:47 UTC
First step to fixing this: https://invent.kde.org/frameworks/extra-cmake-modules/-/merge_requests/384

Comment 17 Fedora Fails To Install 2023-09-30 17:35:21 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 39.

Thanks for taking care of it!

Comment 18 Neal Gompa 2023-10-04 11:51:29 UTC
This definitely is still a problem.

Comment 19 Fedora Update System 2023-10-04 11:58:00 UTC
FEDORA-2023-b4a6c241c1 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-b4a6c241c1

Comment 20 Fedora Update System 2023-10-04 11:58:01 UTC
FEDORA-2023-1eda947382 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-1eda947382

Comment 21 Fedora Blocker Bugs Application 2023-10-04 12:08:05 UTC
Proposed as a Freeze Exception for 39-final by Fedora user ngompa using the blocker tracking app because:

 Fixes FTI for breeze-icon-theme-devel

Comment 22 Fedora Update System 2023-10-05 01:49:39 UTC
FEDORA-2023-b4a6c241c1 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-b4a6c241c1`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-b4a6c241c1

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 23 Fedora Fails To Install 2023-10-05 15:49:26 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 40.

Thanks for taking care of it!

Comment 24 Kamil Páral 2023-10-06 10:13:06 UTC
Verified fixed from feedback in the bodhi update

Comment 25 Adam Williamson 2023-10-06 19:13:37 UTC
+4 in https://pagure.io/fedora-qa/blocker-review/issue/1377 , marking accepted.

Comment 26 Fedora Update System 2023-10-07 03:23:41 UTC
FEDORA-2023-b4a6c241c1 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.