Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2222609 - graphviz: FTBFS in Fedora Rawhide with OCaml 5.0
Summary: graphviz: FTBFS in Fedora Rawhide with OCaml 5.0
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: graphviz
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F39FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-07-13 09:27 UTC by Jitka Plesnikova
Modified: 2023-07-13 11:20 UTC (History)
4 users (show)

Fixed In Version: graphviz-8.1.0-4.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-07-13 11:20:30 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)

Description Jitka Plesnikova 2023-07-13 09:27:16 UTC
Description of problem:
Package graphviz fails to build from source wirh OCaml 5.0 in Fedora Rawhide.

gv_ocaml.cpp:806:3: error: 'caml_local_roots' was not declared in this scope; did you mean 'caml_local_roots_ptr'?
  806 |   caml_local_roots = caml__frame; \
      |   ^~~~~~~~~~~~~~~~
gv_ocaml.cpp:883:3: note: in expansion of macro 'CAMLreturn0'
  883 |   CAMLreturn0;
      |   ^~~~~~~~~~~
gv_ocaml.cpp: In function 'void caml_print_list(caml_value_t)':
gv_ocaml.cpp:806:3: error: 'caml_local_roots' was not declared in this scope; did you mean 'caml_local_roots_ptr'?
  806 |   caml_local_roots = caml__frame; \
      |   ^~~~~~~~~~~~~~~~
gv_ocaml.cpp:1100:9: note: in expansion of macro 'CAMLreturn0'
 1100 |         CAMLreturn0;
      |         ^~~~~~~~~~~
gv_ocaml.cpp: In function 'caml_value_t caml_list_nth(caml_value_t, int)':
gv_ocaml.cpp:815:3: error: 'caml_local_roots' was not declared in this scope; did you mean 'caml_local_roots_ptr'?
  815 |   caml_local_roots = caml__frame; \
      |   ^~~~~~~~~~~~~~~~
gv_ocaml.cpp:1109:31: note: in expansion of macro 'CAMLreturn'
 1109 |         if( lst == Val_unit ) CAMLreturn(Val_unit);
      |                               ^~~~~~~~~~
Version-Release number of selected component (if applicable):
8.0.5-2.fc39

Steps to Reproduce:
koji build --scratch f39 graphviz-8.0.5-2.fc39.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/graphviz

Reproducible: Always

Steps to Reproduce:
koji build --scratch f39 graphviz-8.1.0-4.fc39.src.rpm

Comment 1 Jaroslav Škarvada 2023-07-13 10:23:27 UTC
I cannot reproduce:
https://koji.fedoraproject.org/koji/taskinfo?taskID=103304397

Comment 2 Jitka Plesnikova 2023-07-13 11:08:00 UTC
(In reply to Jaroslav Škarvada from comment #1)
> I cannot reproduce:
> https://koji.fedoraproject.org/koji/taskinfo?taskID=103304397

The build was run with Perl 5.36.

However, it seems ocaml errors are fixed now.
https://koji.fedoraproject.org/koji/taskinfo?taskID=103306796

So, I resubmitted the build graphviz-8.1.0-4.fc39 with new Perl 5.38.


Note You need to log in before you can comment on or make changes to this bug.