Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2222635 - F39FailsToInstall: perl-Crypt-OpenSSL-PKCS10
Summary: F39FailsToInstall: perl-Crypt-OpenSSL-PKCS10
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Crypt-OpenSSL-PKCS10
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Wes Hardaker
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 2223434
Blocks: F39FTBFS F39FailsToInstall
TreeView+ depends on / blocked
 
Reported: 2023-07-13 11:32 UTC by Fedora Fails To Install
Modified: 2023-07-19 08:54 UTC (History)
5 users (show)

Fixed In Version: perl-Crypt-OpenSSL-PKCS10-0.20-1.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-07-19 08:54:49 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
CPAN 148807 0 None None None 2023-07-13 15:37:02 UTC

Description Fedora Fails To Install 2023-07-13 11:32:06 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

Your package (perl-Crypt-OpenSSL-PKCS10) Fails To Install in Fedora 39:

can't install perl-Crypt-OpenSSL-PKCS10:
  - nothing provides libperl.so.5.36()(64bit) needed by perl-Crypt-OpenSSL-PKCS10-0.19-5.fc38.x86_64
  - nothing provides perl(:MODULE_COMPAT_5.36.0) needed by perl-Crypt-OpenSSL-PKCS10-0.19-5.fc38.x86_64
  
If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.


If you don't react accordingly to the policy for FTBFS/FTI bugs (https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/), your package may be orphaned in 8+ weeks.


P.S. The data was generated solely from koji buildroot, so it might be newer than the latest compose or the content on mirrors. To reproduce, use the koji/local repo only, e.g. in mock:

    $ mock -r fedora-39-x86_64 --config-opts mirrored=False install perl-Crypt-OpenSSL-PKCS10


P.P.S. If this bug has been reported in the middle of upgrading multiple dependent packages, please consider using side tags: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/#updating-inter-dependent-packages

Thanks!

Comment 1 Petr Pisar 2023-07-13 15:37:03 UTC
perl-Crypt-OpenSSL-PKCS10-0.19-6.fc39 fails to build with perl 5.38.0 because a test crash with a memory corruption:

+ make test
"/usr/bin/perl" -MExtUtils::Command::MM -e 'cp_nonempty' -- PKCS10.bs blib/arch/auto/Crypt/OpenSSL/PKCS10/PKCS10.bs 644
PERL_DL_NONLAZY=1 "/usr/bin/perl" "-MExtUtils::Command::MM" "-MTest::Harness" "-e" "undef *Test::Harness::Switches; test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
-----BEGIN CERTIFICATE REQUEST-----
MIIBPzCBqQIBADAAMIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDCThq/PWHm
mcYbnxkVG+A1T/5GhrhUP1SQp0bz6K2dK54IgpRGE0KuiF2WGAoP/UTMKVA1iSaE
NMVSnkIX22QmyM0X0H17I2opAroppe+au4CVT43TMpbS+a1Ir5cZLZheCVMf3W5+
VICdzT+KTiyZpvttydr0ioxCPNjkpBzIjQIDAQABoAAwDQYJKoZIhvcNAQELBQAD
gYEAKq4bxn6HsxJy/cEH2CFfj7aYizJLZ8spI3+xsEnkmZMdKUZrp6MCJ+aoGagc
l49mM/Uzeig900fZZ4cjcqkb80M06bRYgQFbEJ8q5PlWbaVn5Z+4Y/81esvciKxx
29zydjXUF8YawPh6i9wQ4htdbr6sb1mpx46TF+TSTTmaYSI=
-----END CERTIFICATE REQUEST-----
RSA Private-Key: (1024 bit, 2 primes)
modulus:
 
-----BEGIN CERTIFICATE REQUEST-----
MIIBPzCBqQIBADAAMIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDInzfgZb5Z
t0xWi+JvE1VR9R/vbEBwN6TwLfY/mWknINwcDlLiKFOCYN/2V8BDvUFdTSw3qea/
BCLNoHCU+2bBM3UlxzPSu/csZSc60X5Xfn0QZGlrDkz4ESzQmnYCtJ3a+QEMh6Ac
LU3ov6/68DZYyhYqLHe3dM8spWddf0p/swIDAQABoAAwDQYJKoZIhvcNAQELBQAD
gYEAujIpH0W4GndgMOgyC19QN4cHQnMe+2DlF+SiCU/LyaJB4a+RszMKNhA1ZMGV
PcOjgQmqM0IhZj8nAmZkdJnS/jj5kwl0SSiYi6SXbDJuqZeDDH70gD/cte90f9CW
L2IxLuu53FKwq3SAN2AEMeVnumvZSgTCiOPs7rtmIrdeO2s=
-----END CERTIFICATE REQUEST-----
RSA Private-Key: (1024 bit, 2 primes)
modulus:
 
rsa
-----BEGIN PUBLIC KEY-----
MIGfMA0GCSqGSIb3DQEBAQUAA4GNADCBiQKBgQDInzfgZb5Zt0xWi+JvE1VR9R/v
bEBwN6TwLfY/mWknINwcDlLiKFOCYN/2V8BDvUFdTSw3qea/BCLNoHCU+2bBM3Ul
xzPSu/csZSc60X5Xfn0QZGlrDkz4ESzQmnYCtJ3a+QEMh6AcLU3ov6/68DZYyhYq
LHe3dM8spWddf0p/swIDAQAB
-----END PUBLIC KEY-----
*** stack smashing detected ***: terminated
t/Mytest.t .. 
Failed 3/7 subtests 
Test Summary Report
-------------------
t/Mytest.t (Wstat: 134 (Signal: ABRT, dumped core) Tests: 4 Failed: 0)
  Non-zero wait status: 134

An upstream bug report at <https://rt.cpan.org/Ticket/Display.html?id=148807>.


Note You need to log in before you can comment on or make changes to this bug.