Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2223392 - perl-Test-Vars: FTBFS with Perl 5.38
Summary: perl-Test-Vars: FTBFS with Perl 5.38
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Test-Vars
Version: 39
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F39FTBFS F40FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-07-17 15:04 UTC by Jitka Plesnikova
Modified: 2024-03-05 17:28 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-03-05 17:28:03 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github houseabsolute p5-Test-Vars issues 47 0 None open Updates may be required for new OPs in Perl v5.38 2023-12-28 11:15:32 UTC
Github houseabsolute p5-Test-Vars issues 49 0 None open t/07_stub_sub_bug.t failure with recent perl 2023-07-17 15:05:54 UTC

Description Jitka Plesnikova 2023-07-17 15:04:43 UTC
Description of problem:
Package perl-Test-Vars fails to build from source in Fedora Rawhide with new Perl 5.38.

+ ./Build test
# Testing Test::Vars/0.015
t/00_load.t .............. ok
t/01_all_vars_ok_self.t .. ok
# Test::Vars ignores CompileError.pm because: Intentional compile error.
# Test::Vars ignores ImplicitTopic.pm because: Can't use global $_ in "my" at t/lib/ImplicitTopic.pm line 6, near "my $_ "
t/02_no_warnings.t ....... ok
t/03_warned.t ............ ok
t/04_ignores.t ........... ok
t/05_test_vars.t ......... ok
t/06_vars_ok_self.t ...... ok
#   Failed test 'got expected output from test_vars'
#   at t/07_stub_sub_bug.t line 25.
#     Structures begin differing at:
#          $got->[0][2][1][1] = '$x is used once in &StubSub::foo '
#     $expected->[0][2][1][1] = '$x is used once in &StubSub::foo at t/lib/StubSub.pm line 13'
# Looks like you failed 1 test of 2.
t/07_stub_sub_bug.t ...... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/2 subtests 
t/08_undef_aux_list.t .... ok
t/09_array_slice.t ....... ok
t/10_my_sub.t ............ ok
Test Summary Report
-------------------
t/07_stub_sub_bug.t    (Wstat: 256 (exited 1) Tests: 2 Failed: 1)
  Failed test:  2
  Non-zero exit status: 1
Files=11, Tests=71,  1 wallclock secs ( 0.04 usr  0.01 sys +  1.14 cusr  0.31 csys =  1.50 CPU)
Result: FAIL

Version-Release number of selected component (if applicable):
0.015-9.fc39

Steps to Reproduce:
koji build --scratch f39 perl-Test-Vars-0.015-9.fc39.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/perl-Test-Vars

Reproducible: Always

Comment 1 Fedora Release Engineering 2023-08-16 08:13:07 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 39 development cycle.
Changing version to 39.

Comment 2 Fedora Release Engineering 2023-12-24 04:22:37 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 39.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2023-09-11).

A week before the mass branching of Fedora 40 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 38 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-40/f-40-key-tasks.html

Comment 3 Paul Howarth 2023-12-28 11:15:32 UTC
There has been no movement on this upstream in the last few months and it's beyond my abilities to fix this myself so I think that it'll probably have to be retired.

Comment 4 Fedora Release Engineering 2024-01-21 04:22:29 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 39.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2023-09-11).

A week before the mass branching of Fedora 40 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 38 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-40/f-40-key-tasks.html

Comment 5 Paul Howarth 2024-01-26 14:58:44 UTC
I am working on retiring this package.

Dependent packages:

 * libgadu: build dependency is redundant (Bug #2260472)
 * perl-BZ-Client: build dependency is redundant (Bug #2260475)
 * perl-Code-TidyAll-Plugin-Test-Vars: pointless without Test::Vars (Bug #2260478) - retired today
 * perl-MouseX-SimpleConfig: updated not to use perl-Test-Vars
 * perl-Net-DHCP: build dependency is redundant (Bug #2260481)
 * perl-Software-License-CCpack: updated not to use perl-Test-Vars
 * perl-Test-Apocalypse: might be able to drop affected plugin (Bug #2260493)
 * perl-Test-Mojibake: updated not to use perl-Test-Vars
 * perl-Test-TinyMocker: updated not to use perl-Test-Vars

Comment 6 Paul Howarth 2024-02-13 10:37:21 UTC
I tried retiring perl-Test-Vars today but I'm not sure it worked. My pagure token had expired (hadn't noticed since I rarely use it) so it pushed the "dead.package" change to dist-git but then failed with:

Could not execute retire: The following error occurred while disabling monitoring: Invalid or expired token.

I got a new token and retried the command, which seemed to work:

dead.package found, package or module is already retired. Will not remove files from git or overwrite existing dead.package file.
Monitoring of the project was sucessfully disabled.

However, I'm still listed as owner of the package at https://src.fedoraproject.org/rpms/perl-Test-Vars and I'd expected the package to be orphaned by this point.

I'll give it a few days and wait to see if it gets blocked in koji before raising a releng ticket.
Hopefully I don't have to retire it again for Fedora 40 after today's branch event.

Comment 7 Petr Pisar 2024-02-13 13:47:11 UTC
When I retired a package last time, I hit the same expired token. I did not dare "fedpkg retire" again. Instead I made sure the dead.package is pushed on the git server and then I unassigned from the package by clicking "Orphan". After relengs finish a compose, they will detect that the git repository contains dead.package and retire the package. AFAIK the same procedure will work for Fedora 40 after branching and before releasing beta.

Comment 8 Fedora Admin user for bugzilla script actions 2024-02-14 00:22:17 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 9 Paul Howarth 2024-02-16 14:30:02 UTC
Seems to be retired OK in rawhide but not f40 yet:

https://pagure.io/releng/issue/11959

Comment 10 Paul Howarth 2024-03-05 17:28:03 UTC
Retired in F-40 and Rawhide.


Note You need to log in before you can comment on or make changes to this bug.