Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2223529 - clusterssh: FTBFS with Perl 5.38
Summary: clusterssh: FTBFS with Perl 5.38
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: clusterssh
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jitka Plesnikova
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
Depends On:
Blocks: F39FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-07-18 06:42 UTC by Jitka Plesnikova
Modified: 2023-07-19 11:29 UTC (History)
1 user (show)

Fixed In Version: clusterssh-4.16-9.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-07-19 11:29:59 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github duncs clusterssh issues 153 0 None closed t/15config.t fails with perl 5.37.4 2023-07-18 06:42:21 UTC

Description Jitka Plesnikova 2023-07-18 06:42:10 UTC
Description of problem:
Package clusterssh fails to build from source with Perl 5.38 in Fedora Rawhide.

t/10host.t ............... ok
#   Failed test 'returned ok'
#   at t/15config.t line 546.
#          got: 'die'
#     expected: 'return'
#   Failed test 'Expecting no STDERR'
#   at t/15config.t line 550.
#          got: ''
#     expected: 'Unable to write default $HOME/.clusterssh/config: Is a directory
# 
# '
# Looks like you failed 2 tests of 155.
t/15config.t ............. 
Dubious, test returned 2 (wstat 512, 0x200)
Failed 2/155 subtests 

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/clusterssh

Reproducible: Always

Steps to Reproduce:
koji build --scratch f39 clusterssh-4.16-8.fc38.src.rpm




I've reported it to upstream and they prepared fix for it.


Note You need to log in before you can comment on or make changes to this bug.