Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2224164 - cp2k: FTBFS in Fedora Rawhide
Summary: cp2k: FTBFS in Fedora Rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cp2k
Version: 39
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Cristian Le
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
: 2225743 (view as bug list)
Depends On:
Blocks: F39FTBFS F40FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-07-20 03:52 UTC by Orion Poplawski
Modified: 2024-02-14 08:28 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-02-14 08:28:45 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description Orion Poplawski 2023-07-20 03:52:28 UTC
Description of problem:
Package cp2k fails to build from source in Fedora Rawhide.

Version-Release number of selected component (if applicable):
2023.1-2.fc38

Steps to Reproduce:
koji build --scratch f39 cp2k-2023.1-2.fc38.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/cp2k

/builddir/build/BUILD/cp2k-2023.1/exts/dbcsr/src/mpi/dbcsr_mpiwrap.F:5299:65:
 5299 |          CALL MPI_ALLOC_MEM(mp_size, mp_info, mp_baseptr, mp_res)
      |                                                                 1
Error: Type mismatch in argument 'baseptr' at (1); passed TYPE(c_ptr) to INTEGER(8)
/builddir/build/BUILD/cp2k-2023.1/exts/dbcsr/src/mpi/dbcsr_mpiwrap.F:5299:65:
 5299 |          CALL MPI_ALLOC_MEM(mp_size, mp_info, mp_baseptr, mp_res)
      |                                                                 1
Error: Type mismatch in argument 'baseptr' at (1); passed TYPE(c_ptr) to INTEGER(8)
/builddir/build/BUILD/cp2k-2023.1/exts/dbcsr/src/mpi/dbcsr_mpiwrap.F:5299:65:
 5299 |          CALL MPI_ALLOC_MEM(mp_size, mp_info, mp_baseptr, mp_res)
      |                                                                 1
Error: Type mismatch in argument 'baseptr' at (1); passed TYPE(c_ptr) to INTEGER(8)
/usr/bin/env python3 /usr/bin/fypp -n /builddir/build/BUILD/cp2k-2023.1/exts/dbcsr/src/acc/dbcsr_acc_event.F dbcsr_acc_event.F90
/builddir/build/BUILD/cp2k-2023.1/exts/dbcsr/src/mpi/dbcsr_mpiwrap.F:5299:65:
 5299 |          CALL MPI_ALLOC_MEM(mp_size, mp_info, mp_baseptr, mp_res)
      |                                                                 1
Error: Type mismatch in argument 'baseptr' at (1); passed TYPE(c_ptr) to INTEGER(8)
/builddir/build/BUILD/cp2k-2023.1/exts/dbcsr/src/mpi/dbcsr_mpiwrap.F:5299:65:
 5299 |          CALL MPI_ALLOC_MEM(mp_size, mp_info, mp_baseptr, mp_res)
      |                                                                 1
Error: Type mismatch in argument 'baseptr' at (1); passed TYPE(c_ptr) to INTEGER(8)
/builddir/build/BUILD/cp2k-2023.1/exts/dbcsr/src/mpi/dbcsr_mpiwrap.F:5299:65:
 5299 |          CALL MPI_ALLOC_MEM(mp_size, mp_info, mp_baseptr, mp_res)
      |                                                                 1
Error: Type mismatch in argument 'baseptr' at (1); passed TYPE(c_ptr) to INTEGER(8)

Comment 1 Dominik 'Rathann' Mierzejewski 2023-07-26 21:56:32 UTC
*** Bug 2225743 has been marked as a duplicate of this bug. ***

Comment 2 Fedora Release Engineering 2023-08-16 07:19:47 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 39 development cycle.
Changing version to 39.

Comment 3 Fedora Release Engineering 2023-12-24 04:22:39 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 39.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2023-09-14).

A week before the mass branching of Fedora 40 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 38 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-40/f-40-key-tasks.html

Comment 4 Dominik 'Rathann' Mierzejewski 2024-01-01 17:17:18 UTC
This is being worked on: https://src.fedoraproject.org/rpms/cp2k/pull-request/5 .

Comment 5 Fedora Admin user for bugzilla script actions 2024-01-05 12:16:26 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 6 Fedora Admin user for bugzilla script actions 2024-01-27 00:13:42 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.


Note You need to log in before you can comment on or make changes to this bug.