Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2225909 - goverlay: FTBFS in Fedora rawhide/f39
Summary: goverlay: FTBFS in Fedora rawhide/f39
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: goverlay
Version: 39
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Artem
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F39FTBFS F40FTBFS 2203269
TreeView+ depends on / blocked
 
Reported: 2023-07-25 18:04 UTC by Fedora Release Engineering
Modified: 2023-08-24 05:34 UTC (History)
2 users (show)

Fixed In Version: goverlay-0.9-5.fc40
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-08-24 05:34:35 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2023-07-25 18:04 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2023-07-25 18:04 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2023-07-25 18:04 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2023-07-25 18:04:27 UTC
goverlay failed to build from source in Fedora rawhide/f39

https://koji.fedoraproject.org/koji/taskinfo?taskID=103604547


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
Please fix goverlay at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
goverlay will be orphaned. Before branching of Fedora 40,
goverlay will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 1 Fedora Release Engineering 2023-07-25 18:04:32 UTC
Created attachment 1978159 [details]
build.log

Comment 2 Fedora Release Engineering 2023-07-25 18:04:37 UTC
Created attachment 1978160 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2023-07-25 18:04:40 UTC
Created attachment 1978161 [details]
state.log

Comment 4 Artur Frenszek-Iwicki 2023-07-25 20:04:29 UTC
This build failure seems to be caused by the recent changes to Lazarus packaging.
https://fedoraproject.org/wiki/Changes/F39-Lazarus-repackaging

The default install of Lazarus no longer incudes the Qt5 units.
You can fix this by adding "BuildRequires: lazarus-lcl-qt5" to the spec.

Comment 5 Fedora Release Engineering 2023-08-16 07:57:43 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 39 development cycle.
Changing version to 39.

Comment 6 Fedora Update System 2023-08-24 05:30:40 UTC
FEDORA-2023-8b60778474 has been submitted as an update to Fedora 40. https://bodhi.fedoraproject.org/updates/FEDORA-2023-8b60778474

Comment 7 Fedora Update System 2023-08-24 05:34:35 UTC
FEDORA-2023-8b60778474 has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.