Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2225917 - hedgewars: FTBFS in Fedora rawhide/f39
Summary: hedgewars: FTBFS in Fedora rawhide/f39
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hedgewars
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nikolay Nikolov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F39FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-07-25 18:07 UTC by Fedora Release Engineering
Modified: 2023-08-07 13:25 UTC (History)
5 users (show)

Fixed In Version: hedgewars-1.0.2-5.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-08-05 19:11:56 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2023-07-25 18:07 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2023-07-25 18:07 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2023-07-25 18:07 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2023-07-25 18:07:03 UTC
hedgewars failed to build from source in Fedora rawhide/f39

https://koji.fedoraproject.org/koji/taskinfo?taskID=103607070


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
Please fix hedgewars at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
hedgewars will be orphaned. Before branching of Fedora 40,
hedgewars will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 1 Fedora Release Engineering 2023-07-25 18:07:10 UTC
Created attachment 1978183 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2023-07-25 18:07:14 UTC
Created attachment 1978184 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2023-07-25 18:07:17 UTC
Created attachment 1978185 [details]
state.log

Comment 4 Jens Petersen 2023-07-28 06:45:59 UTC
Btw I see the same failure for x86_64 on F39 and F38 

/builddir/build/BUILD/hedgewars-src-1.0.2/project_files/hwc/rtl/misc.c:223:5: error: call to undeclared function 'glShaderSource'; ISO C99 and later do not support implicit function declarations [-Wimplicit-function-declaration]
    glShaderSource(shader, count, (const char * const *)string, length);
    ^
1 warning and 1 error generated.
gmake[2]: *** [project_files/hwc/rtl/CMakeFiles/fpcrtl.dir/build.make:93: project_files/hwc/rtl/CMakeFiles/fpcrtl.dir/misc.c.o] Error 1
gmake[2]: *** Waiting for unfinished jobs....

Comment 5 Hans de Goede 2023-07-30 18:11:06 UTC
I just tried a x86_64 mockbuild for F38 and it succeeds now, no glShaderSource error.

Also tried it for rawhide and I get a new error there now:

File "_none_", line 1:
Alert ocaml_deprecated_auto_include: 
OCaml's lib directory layout changed in 5.0. The unix subdirectory has been
automatically added to the search path, but you should add -I +unix to the
command-line to silence this alert (e.g. by adding unix to the list of
libraries in your dune file, or adding use_unix to your _tags file for
ocamlbuild, or using -package unix for ocamlfind).

File "freetennis.ml", line 6654, characters 31-47:
6654 |      let mayb = translateName (String.lowercase !p0Name ) in
                                      ^^^^^^^^^^^^^^^^
Error: Unbound value String.lowercase

I'm afraid my ocaml skills are pretty much non existent. Does this Unbound value String.lowercase indicate a missing include or ...?

Comment 6 Hans de Goede 2023-07-30 18:12:18 UTC
Ugh never mind I was mockbuilding freetennis while responding to the hedgewars FTFBS (both are FTBFS), please ignore.

Comment 7 Gwyn Ciesla 2023-08-01 13:29:18 UTC
https://issues.hedgewars.org/show_bug.cgi?id=855

Comment 8 Hans de Goede 2023-08-05 19:02:48 UTC
(In reply to Gwyn Ciesla from comment #7)
> https://issues.hedgewars.org/show_bug.cgi?id=855

I've worked around this for now by adding the following to the .spec file before %cmake:

export CFLAGS="%{build_cflags} -DGL_GLEXT_PROTOTYPES"
export CXXFLAGS="%{build_cxxflags} -DGL_GLEXT_PROTOTYPES"

and I've started a koji build to fix the FTBFS.

Comment 9 Fedora Update System 2023-08-05 19:09:11 UTC
FEDORA-2023-d4dd820b59 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-d4dd820b59

Comment 10 Fedora Update System 2023-08-05 19:11:56 UTC
FEDORA-2023-d4dd820b59 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 11 Gwyn Ciesla 2023-08-07 13:25:16 UTC
Thank you!


Note You need to log in before you can comment on or make changes to this bug.