Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2226087 - perl-Parallel-Prefork: FTBFS in Fedora rawhide/f39
Summary: perl-Parallel-Prefork: FTBFS in Fedora rawhide/f39
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-Parallel-Prefork
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ralf Corsepius
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F39FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-07-25 18:55 UTC by Fedora Release Engineering
Modified: 2023-07-26 14:06 UTC (History)
3 users (show)

Fixed In Version: perl-Parallel-Prefork-0.18-23.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-07-26 11:38:27 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2023-07-25 18:55 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2023-07-25 18:55 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2023-07-25 18:55 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2023-07-25 18:55:13 UTC
perl-Parallel-Prefork failed to build from source in Fedora rawhide/f39

https://koji.fedoraproject.org/koji/taskinfo?taskID=103658230


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
Please fix perl-Parallel-Prefork at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
perl-Parallel-Prefork will be orphaned. Before branching of Fedora 40,
perl-Parallel-Prefork will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 1 Fedora Release Engineering 2023-07-25 18:55:17 UTC
Created attachment 1978656 [details]
build.log

Comment 2 Fedora Release Engineering 2023-07-25 18:55:21 UTC
Created attachment 1978657 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2023-07-25 18:55:24 UTC
Created attachment 1978658 [details]
state.log

Comment 4 Ralf Corsepius 2023-07-26 11:55:22 UTC
Jitka, what was the cause of this FTBFS?

I haven't a chance to look into this, and you closed this BZ without giving any rationale.

Comment 5 Jitka Plesnikova 2023-07-26 12:49:35 UTC
This error is in build.log:

#   Failed test 'wait_all_children does not block'
#   at t/07-wait-all-children-does-not-block.t line 22.
# Looks like you failed 1 test of 1.
t/07-wait-all-children-does-not-block.t .. 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests 

I didn't find the source of failure. I just tried to re-run the build and it passed.
It is not  possible to reproduce the failure now.

Comment 6 Ralf Corsepius 2023-07-26 14:06:43 UTC
(In reply to Jitka Plesnikova from comment #5)
> I didn't find the source of failure. I just tried to re-run the build and it
> passed.

Thanks.

My guess: Fedora's befamed notorious s390x buildsys (in-) stability:

cf. https://kojipkgs.fedoraproject.org//work/tasks/8362/103658362/hw_info.log
CPU info:
Architecture:                    s390x

I've seen too many of these s390x build-failures, to waste more words.


Note You need to log in before you can comment on or make changes to this bug.