Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2226152 - python-asyncpg: FTBFS in Fedora rawhide/f39
Summary: python-asyncpg: FTBFS in Fedora rawhide/f39
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-asyncpg
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ben Beasley
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: F39FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-07-25 19:09 UTC by Fedora Release Engineering
Modified: 2023-07-25 20:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-07-25 20:13:24 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2023-07-25 19:09 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2023-07-25 19:09 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2023-07-25 19:09 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2023-07-25 19:09:35 UTC
python-asyncpg failed to build from source in Fedora rawhide/f39

https://koji.fedoraproject.org/koji/taskinfo?taskID=103675838


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
Please fix python-asyncpg at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
python-asyncpg will be orphaned. Before branching of Fedora 40,
python-asyncpg will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 1 Fedora Release Engineering 2023-07-25 19:09:39 UTC
Created attachment 1978858 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2023-07-25 19:09:44 UTC
Created attachment 1978859 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2023-07-25 19:09:46 UTC
Created attachment 1978860 [details]
state.log

Comment 4 Ben Beasley 2023-07-25 19:29:28 UTC
=================================== FAILURES ===================================
________ TestExecuteMany.test_executemany_server_failure_during_writes _________
Traceback (most recent call last):
  File "/builddir/build/BUILD/asyncpg-0.28.0/tests/test_execute.py", line 215, in test_executemany_server_failure_during_writes
    self.assertLess(pos, 128, 'should stop early')
  File "/usr/lib64/python3.12/unittest/case.py", line 1257, in assertLess
    self.fail(self._formatMessage(msg, standardMsg))
  File "/usr/lib64/python3.12/unittest/case.py", line 715, in fail
    raise self.failureException(msg)
AssertionError: 128 not less than 128 : should stop early
=========================== short test summary info ============================
FAILED tests/test_execute.py::TestExecuteMany::test_executemany_server_failure_during_writes
====== 1 failed, 295 passed, 2 skipped, 1 deselected in 72.21s (0:01:12) =======

I don’t know the root cause, but I have encountered this as a flaky failure before. Another rebuild attempt should fix it.


Note You need to log in before you can comment on or make changes to this bug.