Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2226284 - python-pvc: FTBFS in Fedora rawhide/f39
Summary: python-pvc: FTBFS in Fedora rawhide/f39
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pvc
Version: 39
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Raphael Groner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 2220418 (view as bug list)
Depends On: 2226308 2226365
Blocks: F39FTBFS F39FailsToInstall F40FTBFS PYTHON3.12
TreeView+ depends on / blocked
 
Reported: 2023-07-25 19:39 UTC by Fedora Release Engineering
Modified: 2023-10-01 03:37 UTC (History)
5 users (show)

Fixed In Version: python-pvc-0.3.0-20.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-10-01 03:37:27 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2023-07-25 19:39 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2023-07-25 19:39 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2023-07-25 19:39 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2023-07-25 19:39:00 UTC
python-pvc failed to build from source in Fedora rawhide/f39

https://koji.fedoraproject.org/koji/taskinfo?taskID=103690112


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
Please fix python-pvc at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
python-pvc will be orphaned. Before branching of Fedora 40,
python-pvc will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 1 Fedora Release Engineering 2023-07-25 19:39:04 UTC
Created attachment 1979236 [details]
build.log

Comment 2 Fedora Release Engineering 2023-07-25 19:39:07 UTC
Created attachment 1979237 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2023-07-25 19:39:10 UTC
Created attachment 1979238 [details]
state.log

Comment 4 Raphael Groner 2023-07-29 10:16:27 UTC
Error: 
 Problem 1: conflicting requests
  - nothing provides python(abi) = 3.11 needed by python3-pyvmomi-7.0.3-6.fc39.noarch from build
  - nothing provides python3.11dist(requests) >= 2.3 needed by python3-pyvmomi-7.0.3-6.fc39.noarch from build
  - nothing provides python3.11dist(six) >= 1.7.3 needed by python3-pyvmomi-7.0.3-6.fc39.noarch from build
 Problem 2: conflicting requests
  - nothing provides python(abi) = 3.11 needed by python3-vconnector-0.6.0-11.fc38.noarch from build
  - nothing provides python3.11dist(docopt) >= 0.6.2 needed by python3-vconnector-0.6.0-11.fc38.noarch from build
  - nothing provides python3.11dist(tabulate) >= 0.8.3 needed by python3-vconnector-0.6.0-11.fc38.noarch from build
(try to add '--skip-broken' to skip uninstallable packages)

Comment 5 Raphael Groner 2023-07-30 06:00:01 UTC
*** Bug 2220418 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Release Engineering 2023-08-16 08:02:45 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 39 development cycle.
Changing version to 39.

Comment 7 Miro Hrončok 2023-09-21 09:40:23 UTC
Raphael, I see you assigned this bugzilla almost 2 months ago. Have you made any progress?

The package fails to install and fails to build. Fedora 39 Beta was just released. Is it probable that this will be fixed (or worked around) in time for the Fedora 39 Final Freeze (2023-10-03)? If not, could you please consider retiring the package, so we can obsolete it and unblock clean upgrades to Fedora 39? A retired package can be reintroduced later during the lifetime of Fedora 39.

Comment 8 Raphael Groner 2023-09-22 05:39:41 UTC
Currently I'm busy with daily work. As a community member I'm doing my packaging contributions in my rare spare time -sorry. Understood that Final Freeze is coming, so will see if I can afford something shortly in next couple of weeks.

Maybe just another rebuilds are sufficient for dependencies in correct order? As my comment #4 tells there was an issue with dependency python-pyvmomi but I managed to patch & build successfully.

It'd be sad to see my next package get orphaned.

Comment 9 Elliott Sales de Andrade 2023-09-22 06:14:15 UTC
This just required a small tweak to the sed.

Comment 10 Raphael Groner 2023-09-22 06:26:16 UTC
(In reply to Elliott Sales de Andrade from comment #9)
> This just required a small tweak to the sed.

True. Version branch 7.x of pyvmomi as dependency is legacy for upstream and not expected to mainly developed any further, so downstream patches needed in compatibility case. But that's out of scope here for pvc frontend with another upstream.

Comment 11 Fedora Update System 2023-09-22 06:56:26 UTC
FEDORA-2023-05814fcc72 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-05814fcc72

Comment 12 Fedora Update System 2023-09-23 02:13:11 UTC
FEDORA-2023-05814fcc72 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-05814fcc72`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-05814fcc72

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Fails To Install 2023-09-23 11:05:44 UTC
Hello,

Please note that this comment was generated automatically by https://pagure.io/releng/blob/main/f/scripts/ftbfs-fti/follow-policy.py
If you feel that this output has mistakes, please open an issue at https://pagure.io/releng/

All subpackages of a package against which this bug was filled are now installable or removed from Fedora 40.

Thanks for taking care of it!

Comment 14 Fedora Update System 2023-10-01 03:37:27 UTC
FEDORA-2023-05814fcc72 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.