Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2226290 - python-pydocstyle: FTBFS in Fedora rawhide/f39
Summary: python-pydocstyle: FTBFS in Fedora rawhide/f39
Keywords:
Status: CLOSED DUPLICATE of bug 2220426
Alias: None
Product: Fedora
Classification: Fedora
Component: python-pydocstyle
Version: 39
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tadej Janež
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F39FTBFS F40FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-07-25 19:40 UTC by Fedora Release Engineering
Modified: 2023-08-19 11:49 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-08-19 11:49:09 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2023-07-25 19:40 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2023-07-25 19:40 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2023-07-25 19:40 UTC, Fedora Release Engineering
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github PyCQA pydocstyle issues 646 0 None open test_simple_fstring and test_fstring_with_args fail with Python 3.12 beta 2023-08-04 12:27:35 UTC

Description Fedora Release Engineering 2023-07-25 19:40:15 UTC
python-pydocstyle failed to build from source in Fedora rawhide/f39

https://koji.fedoraproject.org/koji/taskinfo?taskID=103690610


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
Please fix python-pydocstyle at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
python-pydocstyle will be orphaned. Before branching of Fedora 40,
python-pydocstyle will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 1 Fedora Release Engineering 2023-07-25 19:40:20 UTC
Created attachment 1979254 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2023-07-25 19:40:23 UTC
Created attachment 1979255 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2023-07-25 19:40:26 UTC
Created attachment 1979256 [details]
state.log

Comment 4 Tadej Janež 2023-08-04 12:27:35 UTC
As I wrote in https://bugzilla.redhat.com/show_bug.cgi?id=2220426:

2 tests from Pydocstyle's test suite are failing on Python 3.12.

I've reported this to upstream: https://github.com/PyCQA/pydocstyle/issues/646.

Upstream commented that this is because Python 3.12 changed how strings are tokenized and that broke most things.

Comment 5 Fedora Release Engineering 2023-08-16 08:02:54 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 39 development cycle.
Changing version to 39.

Comment 6 Miro Hrončok 2023-08-19 11:49:09 UTC

*** This bug has been marked as a duplicate of bug 2220426 ***


Note You need to log in before you can comment on or make changes to this bug.