Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2226415 - rust-psa-crypto-sys: FTBFS in Fedora rawhide/f39
Summary: rust-psa-crypto-sys: FTBFS in Fedora rawhide/f39
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rust-psa-crypto-sys
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F39FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-07-25 20:07 UTC by Fedora Release Engineering
Modified: 2023-07-28 08:01 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-07-27 19:19:30 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2023-07-25 20:07 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2023-07-25 20:07 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2023-07-25 20:07 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2023-07-25 20:07:19 UTC
rust-psa-crypto-sys failed to build from source in Fedora rawhide/f39

https://koji.fedoraproject.org/koji/taskinfo?taskID=103720248


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
Please fix rust-psa-crypto-sys at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
rust-psa-crypto-sys will be orphaned. Before branching of Fedora 40,
rust-psa-crypto-sys will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 1 Fedora Release Engineering 2023-07-25 20:07:25 UTC
Created attachment 1979619 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2023-07-25 20:07:29 UTC
Created attachment 1979620 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2023-07-25 20:07:32 UTC
Created attachment 1979621 [details]
state.log

Comment 4 Fabio Valentini 2023-07-27 19:19:30 UTC
This failure is caused by an incompatibility of bindgen v0.59 with LLVM / Clang 16.
I think the update to v0.10.0 should fix that, but it looks like that is blocked by other things.

For now, I've backported the upstream change to support for bindgen v0.63 / Clang 16, which is likely the smallest possible change that fixes the FTBFS issue.
https://bodhi.fedoraproject.org/updates/FEDORA-2023-17039b56aa

Comment 5 Peter Robinson 2023-07-28 08:01:46 UTC
> I think the update to v0.10.0 should fix that, but it looks like that is
> blocked by other things.

It's on my todo list to update the parsec stack, just been busy with a lot of other deadlines.


Note You need to log in before you can comment on or make changes to this bug.