Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2226507 - weechat: FTBFS in Fedora rawhide/f39
Summary: weechat: FTBFS in Fedora rawhide/f39
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: weechat
Version: 39
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Paul P Komkoff Jr
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 2133353
Blocks: F39FTBFS F40FTBFS 2222649
TreeView+ depends on / blocked
 
Reported: 2023-07-25 20:26 UTC by Fedora Release Engineering
Modified: 2023-09-02 01:33 UTC (History)
7 users (show)

Fixed In Version: weechat-4.0.4-3.fc39 weechat-4.0.4-3.fc38 weechat-4.0.4-3.fc37
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-08-28 16:36:56 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2023-07-25 20:26 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2023-07-25 20:26 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2023-07-25 20:26 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2023-07-25 20:26:18 UTC
weechat failed to build from source in Fedora rawhide/f39

https://koji.fedoraproject.org/koji/taskinfo?taskID=103752472


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
Please fix weechat at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
weechat will be orphaned. Before branching of Fedora 40,
weechat will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 1 Fedora Release Engineering 2023-07-25 20:26:28 UTC
Created attachment 1979852 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2023-07-25 20:26:31 UTC
Created attachment 1979853 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2023-07-25 20:26:34 UTC
Created attachment 1979854 [details]
state.log

Comment 4 Tim Flink 2023-08-15 21:58:21 UTC
I've been working on this and I have a package for the latest 4.0.3 that builds but fails the tests under F39 and F40. From the upstream bug report [1], it sounds like any non-ascii characters will not display correctly even if I disabled the tests. It seems like there was a change in perl 5.38 which forces a locale change when embedding perl in C [2] like weechat does.

I've confirmed this by building in F38 and F37 (perl 5.36) - the test suite passes with no issues. It only fails with F39 and F40 as those have perl 5.38. If I build with -DENABLE_PERL=NO, the build and test also finish under F40.

It seems like we're left with some less than ideal options:

1. Leave the weechat package as FTBFS until the upstream issue is solved
2. Solve the issue in weechat code even though they seem to want to wait for upstream perl to fix it
3. Ask the perl packagers to patch out the upstream change [3] and hope that doesn't break anything.
4. Disable the tests and ship something that can't handle more than ASCII and will fail in strange ways if weechat ever sees a non-ASCII character
5. Disable the perl bindings until the upstream issue has been resolved

My instinct is to go with 5 and try to figure out how to announce this change in the build for anyone who uses the perl bindings. Are there other thoughts or suggestions? I still need to do more testing of the perl-disabled build to be more sure there aren't big side-effects but wanted to get the question out there for more opinions.

[1] https://github.com/weechat/weechat/issues/1996
[2] https://github.com/Perl/perl5/issues/21366
[3] https://github.com/Perl/perl5/commit/7af2d2037375d58e700f9e1b217efb2c4db66133

Comment 5 Fedora Release Engineering 2023-08-16 08:05:32 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 39 development cycle.
Changing version to 39.

Comment 6 Mamoru TASAKA 2023-08-16 09:38:24 UTC
Note that there is perl5_38 issue (wrt LC_CTYPE) on F-40/39, even if trying to build weechat 4.0.3 on F-38,
I see test failure on i686 and aarch64.

Tim, does your srpm builds on i686 / aarch64?

Comment 7 Tim Flink 2023-08-16 15:42:08 UTC
(In reply to Mamoru TASAKA from comment #6)
> Note that there is perl5_38 issue (wrt LC_CTYPE) on F-40/39, even if trying
> to build weechat 4.0.3 on F-38,
> I see test failure on i686 and aarch64.
> 
> Tim, does your srpm builds on i686 / aarch64?

It turns out that my srpm does not pass tests on i686 or aarch64 [1]. Is this something you're tracking or working on?


[1] https://copr.fedorainfracloud.org/coprs/tflink/weechat-testing/build/6306016/

Comment 8 Mamoru TASAKA 2023-08-17 03:10:53 UTC
Yes, these failures on i686 or aarch64 in [1] are the same failures I am also seeing,
however I have not tried to investigate the cause yet.

Comment 9 Mamoru TASAKA 2023-08-17 15:11:27 UTC
Current status:

* For F-40/F-39 perl5_38 issue, if we only care for making test pass, I wrote the workaround as https://github.com/weechat/weechat/issues/1996#issuecomment-1680146238
* For F-38 aarch64 test failure, the cause is now identified, with possible solution: https://github.com/weechat/weechat/issues/1997
* For F-38 i686 test failure, well, firstly I am not sure if weechat on Fedora is going to updated to 4.0.3 on stable branches (i.e. on F-38 and below).
  Then if we are to upgrade to 4.0.3 on Fedora on F-39/40 only, then I am not sure if we should investigate i686 test failure.
  Currently Fedora encourages to drop i686 support:
  https://fedoraproject.org/wiki/Changes/EncourageI686LeafRemoval
  and the upstream probably is not interested on 32bit.

Comment 10 Mamoru TASAKA 2023-08-18 10:50:54 UTC
The upstream says they are still going to support 32bit, so for test failures on i686
I am going to file bugs on the upstream github.

Comment 11 Mamoru TASAKA 2023-08-19 09:18:09 UTC
Current weechat git head builds on Fedora 38 for all arches, including i686 and aarch64.
So the left issue is perl issue on F-40/39 : https://github.com/weechat/weechat/issues/1996

Comment 12 Mamoru TASAKA 2023-08-22 08:34:21 UTC
@tflink 

Current weechat github head seems to compile with perl 5.38 on all archs. Would you check this?

Comment 13 Tim Flink 2023-08-22 21:18:55 UTC
I did a new build of 4.0.4 and perl enabled, the build completes and weechat is working on my x86_64 system.

A build in COPR shows that builds on all arches are passing (check is disabled on s390) [1]

Do you have a change ready to go for a PR or should I clean mine [2] up a bit more and submit it as a PR?

[1] https://copr.fedorainfracloud.org/coprs/tflink/weechat-testing/build/6335252/
[2] https://tflink.fedorapeople.org/packages/weechat/weechat.spec

Comment 14 Tim Flink 2023-08-22 21:32:45 UTC
NVM, it looks like someone beat us both to the PR and re-enabled php integration at the same time. The CI tests failed but it failed on getting the sources from weechat.org and indicates that the source tarball wasn't available when the CI job ran.

PR: https://src.fedoraproject.org/rpms/weechat/pull-request/16
CI Failure: https://osci-jenkins-1.ci.fedoraproject.org/job/fedora-ci/job/dist-git-build-pipeline/job/master/38528/console

Comment 15 Mamoru TASAKA 2023-08-23 08:08:36 UTC
(BTW I am not the maintainer of weechat, but if you want I can merge the PRs using provenpackager power if the PRs look good for you - or if you submit another PR and you are confident, I can merge it. Let me know it. Again I am not the maintainer of weechat, however I want to fix FTI anyway.)

Comment 16 Jitka Plesnikova 2023-08-23 12:30:52 UTC
Please update also branch f39 to solve FTBFS issue.

Comment 17 Fedora Update System 2023-08-23 21:17:37 UTC
FEDORA-2023-8b7f5c2dc5 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-8b7f5c2dc5

Comment 18 Fedora Update System 2023-08-23 21:17:44 UTC
FEDORA-2023-2fb279dd0b has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-2fb279dd0b

Comment 19 Fedora Update System 2023-08-23 21:17:50 UTC
FEDORA-2023-cf712ced14 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-cf712ced14

Comment 20 Fedora Update System 2023-08-24 01:24:14 UTC
FEDORA-2023-8b7f5c2dc5 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-8b7f5c2dc5`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-8b7f5c2dc5

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 21 Fedora Update System 2023-08-24 01:38:13 UTC
FEDORA-2023-2fb279dd0b has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-2fb279dd0b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-2fb279dd0b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 22 Fedora Update System 2023-08-24 02:23:09 UTC
FEDORA-2023-cf712ced14 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-cf712ced14`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-cf712ced14

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 23 Fedora Update System 2023-08-24 13:25:56 UTC
FEDORA-2023-1ffebac48b has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-1ffebac48b

Comment 24 Fedora Update System 2023-08-24 13:26:02 UTC
FEDORA-2023-c1899f70bf has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-c1899f70bf

Comment 25 Fedora Update System 2023-08-24 13:26:16 UTC
FEDORA-2023-d2ecace1dd has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-d2ecace1dd

Comment 26 Fedora Update System 2023-08-25 01:42:21 UTC
FEDORA-2023-1ffebac48b has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-1ffebac48b`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-1ffebac48b

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 27 Fedora Update System 2023-08-25 02:04:24 UTC
FEDORA-2023-c1899f70bf has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-c1899f70bf`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-c1899f70bf

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 28 Fedora Update System 2023-08-25 02:21:47 UTC
FEDORA-2023-d2ecace1dd has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-d2ecace1dd`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-d2ecace1dd

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 29 Fedora Update System 2023-08-28 16:36:56 UTC
FEDORA-2023-1ffebac48b has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 30 Fedora Update System 2023-09-02 01:15:36 UTC
FEDORA-2023-c1899f70bf has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 31 Fedora Update System 2023-09-02 01:33:21 UTC
FEDORA-2023-d2ecace1dd has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.