Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2226523 - rust-bytecheck: FTBFS in Fedora rawhide/f39
Summary: rust-bytecheck: FTBFS in Fedora rawhide/f39
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rust-bytecheck
Version: 39
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rust SIG
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: F39FTBFS F40FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-07-25 20:29 UTC by Fedora Release Engineering
Modified: 2024-02-04 17:54 UTC (History)
2 users (show)

Fixed In Version: rust-bytecheck-0.6.12-1.fc40
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2024-02-04 17:54:24 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2023-07-25 20:30 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2023-07-25 20:30 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2023-07-25 20:30 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2023-07-25 20:29:58 UTC
rust-bytecheck failed to build from source in Fedora rawhide/f39

https://koji.fedoraproject.org/koji/taskinfo?taskID=103764628


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
Please fix rust-bytecheck at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
rust-bytecheck will be orphaned. Before branching of Fedora 40,
rust-bytecheck will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 1 Fedora Release Engineering 2023-07-25 20:30:03 UTC
Created attachment 1979901 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2023-07-25 20:30:07 UTC
Created attachment 1979902 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2023-07-25 20:30:10 UTC
Created attachment 1979903 [details]
state.log

Comment 4 Fabio Valentini 2023-07-26 11:51:11 UTC
Caused by a test failure with Rust 1.71 (and as such, is not specific to rawhide):

```
running 1 test
test src/lib.rs - (line 23) ... FAILED
failures:
---- src/lib.rs - (line 23) stdout ----
Test executable failed (exit status: 101).
stderr:
thread 'main' panicked at 'called `Result::unwrap()` on an `Err` value: StructCheckError { field_name: "c", inner: CharCheckError { invalid_value: 51646506 } }', src/lib.rs:45:7
stack backtrace:
(backtrace excluded, since it's just the panic from the unwrap call)
failures:
    src/lib.rs - (line 23)
test result: FAILED. 0 passed; 1 failed; 0 ignored; 0 measured; 0 filtered out; finished in 0.18s
error: doctest failed, to rerun pass `--doc`
error: 1 target failed:
    `--doc`
```

I've reported this upstream since the failure is reproducible from upstream git:
https://github.com/rkyv/bytecheck/issues/32

Comment 5 Fedora Release Engineering 2023-08-16 08:05:47 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 39 development cycle.
Changing version to 39.

Comment 6 Fedora Update System 2024-02-04 17:52:14 UTC
FEDORA-2024-023397a3da has been submitted as an update to Fedora 40. https://bodhi.fedoraproject.org/updates/FEDORA-2024-023397a3da

Comment 7 Fedora Update System 2024-02-04 17:54:24 UTC
FEDORA-2024-023397a3da has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.