Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2226525 - rust-cool_asserts: FTBFS in Fedora rawhide/f39
Summary: rust-cool_asserts: FTBFS in Fedora rawhide/f39
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: rust-cool_asserts
Version: 39
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rust SIG
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: F39FTBFS F40FTBFS
TreeView+ depends on / blocked
 
Reported: 2023-07-25 20:30 UTC by Fedora Release Engineering
Modified: 2023-10-05 02:02 UTC (History)
3 users (show)

Fixed In Version: rust-cool_asserts-1.1.1-3.fc39 rust-cool_asserts-1.1.1-3.fc37 rust-cool_asserts-1.1.1-3.fc38 rust-cool_asserts-1.1.1-3.el9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-29 00:19:28 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
build.log (deleted)
2023-07-25 20:30 UTC, Fedora Release Engineering
no flags Details
root.log (deleted)
2023-07-25 20:30 UTC, Fedora Release Engineering
no flags Details
state.log (deleted)
2023-07-25 20:30 UTC, Fedora Release Engineering
no flags Details

Description Fedora Release Engineering 2023-07-25 20:30:25 UTC
rust-cool_asserts failed to build from source in Fedora rawhide/f39

https://koji.fedoraproject.org/koji/taskinfo?taskID=103764652


For details on the mass rebuild see:

https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
Please fix rust-cool_asserts at your earliest convenience and set the bug's status to
ASSIGNED when you start fixing it. If the bug remains in NEW state for 8 weeks,
rust-cool_asserts will be orphaned. Before branching of Fedora 40,
rust-cool_asserts will be retired, if it still fails to build.

For more details on the FTBFS policy, please visit:
https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/

Comment 1 Fedora Release Engineering 2023-07-25 20:30:29 UTC
Created attachment 1979907 [details]
build.log

file build.log too big, will only attach last 32768 bytes

Comment 2 Fedora Release Engineering 2023-07-25 20:30:33 UTC
Created attachment 1979908 [details]
root.log

file root.log too big, will only attach last 32768 bytes

Comment 3 Fedora Release Engineering 2023-07-25 20:30:35 UTC
Created attachment 1979909 [details]
state.log

Comment 4 Fabio Valentini 2023-07-26 20:46:01 UTC
This seems to be caused by Rust 1.71 (not specific to Rawhide) and can be reproduced from upstream git and with the official Rust toolchain.
Reported upstream: https://github.com/Lucretiel/cool_asserts/issues/5

Comment 5 Fedora Release Engineering 2023-08-16 08:05:48 UTC
This bug appears to have been reported against 'rawhide' during the Fedora Linux 39 development cycle.
Changing version to 39.

Comment 6 Fedora Update System 2023-09-26 21:56:36 UTC
FEDORA-EPEL-2023-da6fcd09db has been submitted as an update to Fedora EPEL 9. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-da6fcd09db

Comment 7 Fedora Update System 2023-09-26 21:56:37 UTC
FEDORA-2023-b7dceefc93 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-b7dceefc93

Comment 8 Fedora Update System 2023-09-26 21:56:38 UTC
FEDORA-2023-4abbc92033 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-4abbc92033

Comment 9 Fedora Update System 2023-09-27 01:26:34 UTC
FEDORA-2023-4abbc92033 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-4abbc92033`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-4abbc92033

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 10 Fedora Update System 2023-09-27 01:29:58 UTC
FEDORA-2023-cb6d55dd23 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-cb6d55dd23`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-cb6d55dd23

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2023-09-27 01:36:23 UTC
FEDORA-2023-b7dceefc93 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-b7dceefc93`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-b7dceefc93

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Fedora Update System 2023-09-27 02:40:43 UTC
FEDORA-EPEL-2023-da6fcd09db has been pushed to the Fedora EPEL 9 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2023-da6fcd09db

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 13 Fedora Update System 2023-09-29 00:19:28 UTC
FEDORA-2023-4abbc92033 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Fedora Update System 2023-10-04 15:48:23 UTC
FEDORA-2023-cb6d55dd23 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 15 Fedora Update System 2023-10-04 15:51:01 UTC
FEDORA-2023-b7dceefc93 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 16 Fedora Update System 2023-10-05 02:02:15 UTC
FEDORA-EPEL-2023-da6fcd09db has been pushed to the Fedora EPEL 9 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.