Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2227974 - [flatpak] Inkscape ModuleNotFoundError: No module named 'urllib3'
Summary: [flatpak] Inkscape ModuleNotFoundError: No module named 'urllib3'
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: inkscape
Version: 38
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kalev Lember
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-08-01 00:39 UTC by Henry Kroll
Modified: 2023-08-12 04:49 UTC (History)
5 users (show)

Fixed In Version: inkscape-1.3-2.fc39 inkscape-1.3-2.fc38 inkscape-stable-3820230803123832.1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-08-12 04:49:34 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Full error output (deleted)
2023-08-01 00:41 UTC, Henry Kroll
no flags Details

Description Henry Kroll 2023-08-01 00:39:01 UTC
Error message appears when clicking "Manage Extensions"

Reproducible: Always

Steps to Reproduce:
1.Click on Extensions menu item
2.Choose "Manage Extensions"
3.Note error messages
Actual Results:  
ModuleNotFoundError: No module named 'urllib3'
full error listing attached, maybe

Expected Results:  
Extensions management console appears

python-urllib3 is installed
But there is no clear way to install it inside the Flatpak sandbox structure.

Comment 1 Henry Kroll 2023-08-01 00:41:16 UTC
Created attachment 1981006 [details]
Full error output

The error message that appears inside the dialog when clicking "Manage Extensions"

Comment 2 Henry Kroll 2023-08-01 01:11:48 UTC
The following from Fredrick Brennan https://gitlab.com/inkscape/inkscape/-/issues/3017 is supposed to fix it.
I can't try it yet until pacman is installed, pending system update.
cd $HOME/.config/inkscape/extensions
source bin/activate && python3 bin/activate_this.py
pacman -S python-gobject python-cssselect
PYTHONPATH=/opt/share/inkscape/extensions/:/usr/lib/python3.10/site-packages/ ./manage_extensions.py

Comment 3 Kalev Lember 2023-08-01 04:42:05 UTC
Thanks - looks like the inkscape package has a missing dep on python3-requests.

Comment 4 Fedora Update System 2023-08-01 05:31:39 UTC
FEDORA-2023-504aaae29b has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-504aaae29b

Comment 5 Fedora Update System 2023-08-01 05:33:04 UTC
FEDORA-2023-504aaae29b has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 6 Kalev Lember 2023-08-01 08:07:58 UTC
Reopening as it still needs a fixed flatpak build. The build system is acting up a bit but hopefully we'll get the flatpak build later today.

Comment 7 Henry Kroll 2023-08-03 07:02:58 UTC
If I just export PYTHONPATH before running inkscape, it also works. FYI

[k@kek:~]$ export PYTHONPATH=/usr/lib/python3.11/site-packages/
[k@kek:~]$ inkscape

Comment 8 Fedora Update System 2023-08-03 14:08:42 UTC
FEDORA-FLATPAK-2023-6e86c120a0 has been submitted as an update to Fedora 38 Flatpaks. https://bodhi.fedoraproject.org/updates/FEDORA-FLATPAK-2023-6e86c120a0

Comment 9 Kalev Lember 2023-08-03 14:14:21 UTC
Sorry for the delay. This should be fixed in the linked build now and the fixed build is on its way to the fedora-testing flatpak remote.

Comment 10 Fedora Update System 2023-08-04 01:52:52 UTC
FEDORA-FLATPAK-2023-6e86c120a0 has been pushed to the Fedora 38 Flatpaks testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-FLATPAK-2023-6e86c120a0

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2023-08-12 04:49:34 UTC
FEDORA-FLATPAK-2023-6e86c120a0 has been pushed to the Fedora 38 Flatpaks stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.