Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2232346 - bind-9.18.19 is available
Summary: bind-9.18.19 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bind
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Menšík
QA Contact: Fedora Extras Quality Assurance
URL: https://downloads.isc.org/isc/bind9/9...
Whiteboard:
Depends On: 2240253
Blocks: 2239874 2239875
TreeView+ depends on / blocked
 
Reported: 2023-08-16 12:35 UTC by Upstream Release Monitoring
Modified: 2023-11-03 18:23 UTC (History)
6 users (show)

Fixed In Version: bind-9.18.19-1.fc38 bind-9.18.19-1.fc37 bind-9.18.19-1.fc39
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-28 01:36:06 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Update to 9.18.18 (#2232346) (deleted)
2023-08-16 12:36 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 9.18.19 (#2232346) (deleted)
2023-09-20 13:00 UTC, Upstream Release Monitoring
no flags Details | Diff


Links
System ID Private Priority Status Summary Last Updated
Fedora Pagure bind-dyndb-ldap pull-request 226 0 None None None 2023-09-25 10:50:33 UTC
Internet Systems Consortium (ISC) isc-projects bind9 issues 3700 0 None closed consider deprecating "dialup" option 2023-09-06 18:04:20 UTC
Internet Systems Consortium (ISC) isc-projects bind9 issues 4032 0 None closed Cannot change max-zone-ttl for dnssec-policy insecure 2023-09-06 18:04:20 UTC
Internet Systems Consortium (ISC) isc-projects bind9 issues 4200 0 None closed Repeated crashes from BIND 9.16.40-S1 and 9.16.42.S1 consistently from either db.c:1263 or db.c:138 2023-09-06 18:04:20 UTC
Internet Systems Consortium (ISC) isc-projects bind9 issues 4215 0 None closed Add ISC_R_TIMEDOUT to the reasons to call dns_zonemgr_unreachableadd in xfrin 2023-09-06 18:04:20 UTC
Internet Systems Consortium (ISC) isc-projects bind9 merge_requests 8285 0 None opened Use range to show value for rbtdb overmempurge_ tests 2023-09-06 19:50:43 UTC

Description Upstream Release Monitoring 2023-08-16 12:35:59 UTC
Releases retrieved: 9.18.18
Upstream release that is considered latest: 9.18.18
Current version/release in rawhide: 9.18.17-1.fc39
URL: https://www.isc.org/bind/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/242117/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/bind

Comment 1 Upstream Release Monitoring 2023-08-16 12:36:08 UTC
Created attachment 1983605 [details]
Update to 9.18.18 (#2232346)

Comment 2 Upstream Release Monitoring 2023-08-16 12:55:20 UTC
the-new-hotness/release-monitoring.org's scratch build of bind-9.18.18-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=104919163

Comment 3 Petr Menšík 2023-09-06 19:50:44 UTC
Build failed on i686 unit test, which is unfortunately reliable:
https://koji.fedoraproject.org/koji/taskinfo?taskID=105833155

Similar problem is also with bind9-next component.

Created upstream helper, but proper fix is not yet known:
https://gitlab.isc.org/isc-projects/bind9/-/merge_requests/8285

Comment 4 Upstream Release Monitoring 2023-09-20 13:00:13 UTC
Releases retrieved: 9.18.19
Upstream release that is considered latest: 9.18.19
Current version/release in rawhide: 9.18.17-1.fc39
URL: https://www.isc.org/bind/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/242117/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/bind

Comment 5 Upstream Release Monitoring 2023-09-20 13:00:23 UTC
Created attachment 1989701 [details]
Update to 9.18.19 (#2232346)

Comment 6 Upstream Release Monitoring 2023-09-20 13:21:26 UTC
the-new-hotness/release-monitoring.org's scratch build of bind-9.18.19-1.fc38.src.rpm for rawhide failed http://koji.fedoraproject.org/koji/taskinfo?taskID=106432494

Comment 7 Petr Menšík 2023-09-22 18:07:32 UTC
Created separate bug #2240253 to solve failures on i686. That issue seems to be really detecting something, but manifests itself for unclear reason only on 32 bit architecture.

Comment 8 Petr Menšík 2023-09-22 18:48:10 UTC
Unfortunately it seems once again the update breaks bind-dyndb-ldap package build:

make[2]: Entering directory '/builddir/build/BUILD/bind-dyndb-ldap-11.10/src'
/bin/sh ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..    -Wall -Wextra -Werror -std=gnu99 -O2 -I /usr/include/bind9 -DHAVE_TLS -DHAVE_THREAD_LOCAL -O2 -flto=auto -ffat-lto-objects -fexceptions -g -grecord-gcc-switches -pipe -Wall -Werror=format-security -Wp,-U_FORTIFY_SOURCE,-D_FORTIFY_SOURCE=3 -Wp,-D_GLIBCXX_ASSERTIONS -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fstack-protector-strong -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1  -m64   -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -fno-omit-frame-pointer -mno-omit-leaf-frame-pointer  -fvisibility=hidden -fno-delete-null-pointer-checks -std=gnu11 -c -o ldap_la-bindcfg.lo `test -f 'bindcfg.c' || echo './'`bindcfg.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -Wall -Wextra -Werror -std=gnu99 -O2 -I /usr/include/bind9 -DHAVE_TLS -DHAVE_THREAD_LOCAL -O2 -flto=auto -ffat-lto-objects -fexceptions -g -grecord-gcc-switches -pipe -Wall -Werror=format-security -Wp,-U_FORTIFY_SOURCE,-D_FORTIFY_SOURCE=3 -Wp,-D_GLIBCXX_ASSERTIONS -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fstack-protector-strong -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -fno-omit-frame-pointer -mno-omit-leaf-frame-pointer -fvisibility=hidden -fno-delete-null-pointer-checks -std=gnu11 -c bindcfg.c  -fPIC -DPIC -o .libs/ldap_la-bindcfg.o
In file included from /usr/include/bind9/isc/atomic.h:19,
                 from /usr/include/bind9/isc/refcount.h:19,
                 from /usr/include/bind9/isccfg/cfg.h:36,
                 from /usr/include/bind9/isccfg/grammar.h:27,
                 from bindcfg.c:10:
/usr/include/bind9/isc/stdatomic.h:29:2: error: #error "isc/stdatomic.h does not support your compiler"
   29 | #error "isc/stdatomic.h does not support your compiler"
      |  ^~~~~
make[2]: *** [Makefile:550: ldap_la-bindcfg.lo] Error 1
make[2]: Leaving directory '/builddir/build/BUILD/bind-dyndb-ldap-11.10/src'
make[2]: *** Waiting for unfinished jobs....
make[2]: Entering directory '/builddir/build/BUILD/bind-dyndb-ldap-11.10/src'
/bin/sh ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I. -I..    -Wall -Wextra -Werror -std=gnu99 -O2 -I /usr/include/bind9 -DHAVE_TLS -DHAVE_THREAD_LOCAL -O2 -flto=auto -ffat-lto-objects -fexceptions -g -grecord-gcc-switches -pipe -Wall -Werror=format-security -Wp,-U_FORTIFY_SOURCE,-D_FORTIFY_SOURCE=3 -Wp,-D_GLIBCXX_ASSERTIONS -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fstack-protector-strong -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1  -m64   -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -fno-omit-frame-pointer -mno-omit-leaf-frame-pointer  -fvisibility=hidden -fno-delete-null-pointer-checks -std=gnu11 -c -o ldap_la-acl.lo `test -f 'acl.c' || echo './'`acl.c
libtool: compile:  gcc -DHAVE_CONFIG_H -I. -I.. -Wall -Wextra -Werror -std=gnu99 -O2 -I /usr/include/bind9 -DHAVE_TLS -DHAVE_THREAD_LOCAL -O2 -flto=auto -ffat-lto-objects -fexceptions -g -grecord-gcc-switches -pipe -Wall -Werror=format-security -Wp,-U_FORTIFY_SOURCE,-D_FORTIFY_SOURCE=3 -Wp,-D_GLIBCXX_ASSERTIONS -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -fstack-protector-strong -specs=/usr/lib/rpm/redhat/redhat-annobin-cc1 -m64 -mtune=generic -fasynchronous-unwind-tables -fstack-clash-protection -fcf-protection -fno-omit-frame-pointer -mno-omit-leaf-frame-pointer -fvisibility=hidden -fno-delete-null-pointer-checks -std=gnu11 -c acl.c  -fPIC -DPIC -o .libs/ldap_la-acl.o
In file included from /usr/include/bind9/isc/atomic.h:19,
                 from /usr/include/bind9/isc/refcount.h:19,
                 from /usr/include/bind9/isccfg/cfg.h:36,
                 from /usr/include/bind9/isccfg/aclconf.h:23,
                 from acl.c:7:
/usr/include/bind9/isc/stdatomic.h:29:2: error: #error "isc/stdatomic.h does not support your compiler"
   29 | #error "isc/stdatomic.h does not support your compiler"

Comment 9 Petr Menšík 2023-09-22 19:42:07 UTC
This is caused by not defined HAVE_STDATOMIC_H in bind-dyndb-ldap. But I haven't found place how it is defined in bind codebase yet.

Comment 10 Petr Menšík 2023-09-25 10:50:33 UTC
It seems now all isc headers require definition of HAVE_STDATOMIC_H before including most of headers. That means config.h from bind-dyndb-ldap must be included BEFORE any bind headers. Added the same detection as bind does into bind-dyndb-ldap, with that it compiles well.

https://pagure.io/bind-dyndb-ldap/pull-request/226

Comment 11 Fedora Update System 2023-09-25 14:52:45 UTC
FEDORA-2023-a2621f58a9 has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-a2621f58a9

Comment 12 Fedora Update System 2023-09-25 15:23:44 UTC
FEDORA-2023-87502c4a93 has been submitted as an update to Fedora 37. https://bodhi.fedoraproject.org/updates/FEDORA-2023-87502c4a93

Comment 13 Fedora Update System 2023-09-25 15:24:31 UTC
FEDORA-2023-687525fcca has been submitted as an update to Fedora 40. https://bodhi.fedoraproject.org/updates/FEDORA-2023-687525fcca

Comment 14 Fedora Update System 2023-09-25 16:43:44 UTC
FEDORA-2023-687525fcca has been pushed to the Fedora 40 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 15 Fedora Update System 2023-09-26 02:22:33 UTC
FEDORA-2023-87502c4a93 has been pushed to the Fedora 37 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-87502c4a93`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-87502c4a93

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 16 Fedora Update System 2023-09-26 02:29:35 UTC
FEDORA-2023-a2621f58a9 has been pushed to the Fedora 38 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-a2621f58a9`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-a2621f58a9

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 17 Fedora Update System 2023-09-26 08:48:30 UTC
FEDORA-2023-b4acb0f7c6 has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-b4acb0f7c6

Comment 18 Fedora Update System 2023-09-27 01:25:32 UTC
FEDORA-2023-b4acb0f7c6 has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-b4acb0f7c6`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-b4acb0f7c6

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 19 Fedora Update System 2023-09-28 01:36:06 UTC
FEDORA-2023-a2621f58a9 has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 20 Fedora Update System 2023-10-11 01:33:20 UTC
FEDORA-2023-87502c4a93 has been pushed to the Fedora 37 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 21 Fedora Update System 2023-11-03 18:23:04 UTC
FEDORA-2023-b4acb0f7c6 has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.