Note: This is a public test instance of Red Hat Bugzilla. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback at bugzilla.redhat.com.
Bug 2233012 - obs-studio-30.0.0-beta3 is available
Summary: obs-studio-30.0.0-beta3 is available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: obs-studio
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Neal Gompa
QA Contact:
URL:
Whiteboard:
Depends On: 2238233
Blocks:
TreeView+ depends on / blocked
 
Reported: 2023-08-21 04:37 UTC by Upstream Release Monitoring
Modified: 2023-09-15 19:54 UTC (History)
5 users (show)

Fixed In Version: obs-studio-30.0.0~beta3-2.fc39
Doc Type: ---
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-09-15 19:54:13 UTC
Type: ---
Embargoed:


Attachments (Terms of Use)
Update to 30.0.0-beta2 (#2233012) (deleted)
2023-08-21 04:37 UTC, Upstream Release Monitoring
no flags Details | Diff
Update to 30.0.0-beta3 (#2233012) (deleted)
2023-09-10 09:59 UTC, Upstream Release Monitoring
no flags Details | Diff

Description Upstream Release Monitoring 2023-08-21 04:37:27 UTC
Releases retrieved: 30.0.0-beta2
Upstream release that is considered latest: 30.0.0-beta2
Current version/release in rawhide: 29.1.3-3.fc39
URL: https://obsproject.com/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/7239/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/obs-studio

Comment 1 Upstream Release Monitoring 2023-08-21 04:37:32 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-df807256/obs-studio.spec']' returned non-zero exit status 1.

StdOut:
warning: Macro expanded in comment on line 23: (c=%{commit}; echo ${c:0:7})

setting SOURCE_DATE_EPOCH=1692576000
error: Bad file: ./obs-studio-30.0.0.tar.gz: No such file or directory

RPM build warnings:
    Macro expanded in comment on line 23: (c=%{commit}; echo ${c:0:7})


RPM build errors:
    Bad file: ./obs-studio-30.0.0.tar.gz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 229, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 2 Upstream Release Monitoring 2023-08-21 04:37:33 UTC
Created attachment 1984260 [details]
Update to 30.0.0-beta2 (#2233012)

Comment 3 Upstream Release Monitoring 2023-09-10 09:59:49 UTC
Releases retrieved: 30.0.0-beta3
Upstream release that is considered latest: 30.0.0-beta3
Current version/release in rawhide: 29.1.3-3.fc39
URL: https://obsproject.com/

Please consult the package updates policy before you issue an update to a stable branch: https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/


More information about the service that created this bug can be found at: https://docs.fedoraproject.org/en-US/package-maintainers/Upstream_Release_Monitoring


Please keep in mind that with any upstream change, there may also be packaging changes that need to be made. Specifically, please remember that it is your responsibility to review the new version to ensure that the licensing is still correct and that no non-free or legally problematic items have been added upstream.


Based on the information from Anitya: https://release-monitoring.org/project/7239/


To change the monitoring settings for the project, please visit:
https://src.fedoraproject.org/rpms/obs-studio

Comment 4 Upstream Release Monitoring 2023-09-10 09:59:52 UTC
Scratch build failed. Details below:

BuilderException: Build failed:
Command '['rpmbuild', '-D', '_sourcedir .', '-D', '_topdir .', '-bs', '/var/tmp/thn-8p29aw71/obs-studio.spec']' returned non-zero exit status 1.

StdOut:
warning: Macro expanded in comment on line 23: (c=%{commit}; echo ${c:0:7})

setting SOURCE_DATE_EPOCH=1694304000
error: Bad file: ./obs-studio-30.0.0.tar.gz: No such file or directory

RPM build warnings:
    Macro expanded in comment on line 23: (c=%{commit}; echo ${c:0:7})


RPM build errors:
    Bad file: ./obs-studio-30.0.0.tar.gz: No such file or directory


Traceback:
  File "/usr/local/lib/python3.11/site-packages/hotness/use_cases/package_scratch_build_use_case.py", line 56, in build
    result = self.builder.build(request.package, request.opts)
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  File "/usr/local/lib/python3.11/site-packages/hotness/builders/koji.py", line 229, in build
    raise BuilderException(

If you think this issue is caused by some bug in the-new-hotness, please report it on the-new-hotness issue tracker: https://github.com/fedora-infra/the-new-hotness/issues

Comment 5 Upstream Release Monitoring 2023-09-10 09:59:54 UTC
Created attachment 1987968 [details]
Update to 30.0.0-beta3 (#2233012)

Comment 6 Fedora Update System 2023-09-11 22:06:24 UTC
FEDORA-2023-543c5612db has been submitted as an update to Fedora 39. https://bodhi.fedoraproject.org/updates/FEDORA-2023-543c5612db

Comment 7 Fedora Update System 2023-09-12 01:24:16 UTC
FEDORA-2023-543c5612db has been pushed to the Fedora 39 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --refresh --advisory=FEDORA-2023-543c5612db`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-543c5612db

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2023-09-15 19:54:13 UTC
FEDORA-2023-543c5612db has been pushed to the Fedora 39 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.